Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

Update and clarify dependencies.

  • Loading branch information...
commit 1da88bb30aa6f20863d75e569e8c4ca085d8a1bc 1 parent 3fa51d5
Tom Preston-Werner mojombo authored
1  .gitignore
@@ -7,3 +7,4 @@ pkg/
7 7 _site/
8 8 .bundle/
9 9 .DS_Store
  10 +bbin/
7 Rakefile
... ... @@ -1,5 +1,6 @@
1 1 require 'rubygems'
2 2 require 'rake'
  3 +require 'rdoc'
3 4 require 'date'
4 5
5 6 $LOAD_PATH.unshift(File.join(File.dirname(__FILE__), *%w[lib]))
@@ -49,6 +50,10 @@ task :default => [:test, :features]
49 50
50 51 require 'rake/testtask'
51 52 Rake::TestTask.new(:test) do |test|
  53 + if `which pygmentize` == ''
  54 + puts "You must have Pygments installed to run the tests."
  55 + exit 1
  56 + end
52 57 test.libs << 'lib' << 'test'
53 58 test.pattern = 'test/**/test_*.rb'
54 59 test.verbose = true
@@ -62,7 +67,7 @@ task :coverage do
62 67 sh "open coverage/index.html"
63 68 end
64 69
65   -require 'rake/rdoctask'
  70 +require 'rdoc/task'
66 71 Rake::RDocTask.new do |rdoc|
67 72 rdoc.rdoc_dir = 'rdoc'
68 73 rdoc.title = "#{name} #{version}"
41 jekyll.gemspec
@@ -5,7 +5,7 @@ Gem::Specification.new do |s|
5 5
6 6 s.name = 'jekyll'
7 7 s.version = '0.11.0'
8   - s.date = '2011-07-10'
  8 + s.date = '2011-11-26'
9 9 s.rubyforge_project = 'jekyll'
10 10
11 11 s.summary = "A simple, blog aware, static site generator."
@@ -22,20 +22,22 @@ Gem::Specification.new do |s|
22 22 s.rdoc_options = ["--charset=UTF-8"]
23 23 s.extra_rdoc_files = %w[README.textile LICENSE]
24 24
25   - s.add_runtime_dependency('liquid', ">= 1.9.0")
26   - s.add_runtime_dependency('classifier', ">= 1.3.1")
27   - s.add_runtime_dependency('directory_watcher', ">= 1.1.1")
28   - s.add_runtime_dependency('maruku', ">= 0.5.9")
29   - s.add_runtime_dependency('kramdown', ">= 0.13.2")
30   - s.add_runtime_dependency('albino', ">= 1.3.2")
  25 + s.add_runtime_dependency('liquid', "~> 2.3")
  26 + s.add_runtime_dependency('classifier', "~> 1.3")
  27 + s.add_runtime_dependency('directory_watcher', "~> 1.1")
  28 + s.add_runtime_dependency('maruku', "~> 0.5")
  29 + s.add_runtime_dependency('kramdown', "~> 0.13")
  30 + s.add_runtime_dependency('albino', "~> 1.3")
31 31
32   - s.add_development_dependency('redgreen', ">= 1.2.2")
33   - s.add_development_dependency('shoulda', ">= 2.11.3")
34   - s.add_development_dependency('rr', ">= 1.0.2")
35   - s.add_development_dependency('cucumber', ">= 0.10.3")
36   - s.add_development_dependency('RedCloth', ">= 4.2.1")
37   - s.add_development_dependency('rdiscount', ">= 1.6.5")
38   - s.add_development_dependency('redcarpet', ">= 1.9.0")
  32 + s.add_development_dependency('rake', "~> 0.9")
  33 + s.add_development_dependency('rdoc', "~> 3.11")
  34 + s.add_development_dependency('redgreen', "~> 1.2")
  35 + s.add_development_dependency('shoulda', "~> 2.11")
  36 + s.add_development_dependency('rr', "~> 1.0")
  37 + s.add_development_dependency('cucumber', "= 1.1")
  38 + s.add_development_dependency('RedCloth', "~> 4.2")
  39 + s.add_development_dependency('rdiscount', "~> 1.6")
  40 + s.add_development_dependency('redcarpet', "~> 1.9")
39 41
40 42 # = MANIFEST =
41 43 s.files = %w[
@@ -46,14 +48,6 @@ Gem::Specification.new do |s|
46 48 Rakefile
47 49 bin/jekyll
48 50 cucumber.yml
49   - doc/output/book.html
50   - doc/output/ch00-preface.asc
51   - doc/output/ch01-quick-start.asc
52   - doc/output/ch02-directory-layout.asc
53   - doc/output/stylesheets/handbookish-quirks.css
54   - doc/output/stylesheets/handbookish.css
55   - doc/output/stylesheets/scribe-quirks.css
56   - doc/output/stylesheets/scribe.css
57 51 features/create_sites.feature
58 52 features/embed_filters.feature
59 53 features/markdown.feature
@@ -64,7 +58,6 @@ Gem::Specification.new do |s|
64 58 features/site_data.feature
65 59 features/step_definitions/jekyll_steps.rb
66 60 features/support/env.rb
67   - g.pl
68 61 jekyll.gemspec
69 62 lib/jekyll.rb
70 63 lib/jekyll/converter.rb
@@ -97,8 +90,6 @@ Gem::Specification.new do |s|
97 90 lib/jekyll/static_file.rb
98 91 lib/jekyll/tags/highlight.rb
99 92 lib/jekyll/tags/include.rb
100   - output/stylesheets/scribe-quirks.css
101   - output/stylesheets/scribe.css
102 93 test/helper.rb
103 94 test/source/.htaccess
104 95 test/source/_includes/sig.markdown
4 lib/jekyll/tags/highlight.rb
@@ -36,9 +36,9 @@ def initialize(tag_name, markup, tokens)
36 36
37 37 def render(context)
38 38 if context.registers[:site].pygments
39   - render_pygments(context, super.join)
  39 + render_pygments(context, super)
40 40 else
41   - render_codehighlighter(context, super.join)
  41 + render_codehighlighter(context, super)
42 42 end
43 43 end
44 44

0 comments on commit 1da88bb

Please sign in to comment.
Something went wrong with that request. Please try again.