Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Made it compile with node 0.6.x #7

Merged
merged 2 commits into from

2 participants

@sugendran

No description provided.

sugendran@su... added some commits
sugendran@sugendran.net make it build caed525
sugendran@sugendran.net change node version eeb58a8
@wezm wezm merged commit 775e660 into from
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on May 8, 2012
  1. make it build

    sugendran@sugendran.net authored
  2. change node version

    sugendran@sugendran.net authored
This page is out of date. Refresh to see the latest.
Showing with 7 additions and 9 deletions.
  1. +6 −6 Cakefile
  2. +1 −3 package.json
View
12 Cakefile
@@ -9,10 +9,10 @@ stdout = process.stdout
process.env["PATH"] = "node_modules/.bin:#{process.env["PATH"]}"
# ANSI Terminal Colors.
-bold = "\033[0;1m"
-red = "\033[0;31m"
-green = "\033[0;32m"
-reset = "\033[0m"
+bold = "\u001b[0;1m"
+red = "\u001b[0;31m"
+green = "\u001b[0;32m"
+reset = "\u001b[0m"
# Log a message with a color.
log = (message, color, explanation) ->
@@ -29,12 +29,12 @@ onerror = (err)->
# Setup development dependencies, not part of runtime dependencies.
task "setup", "Install development dependencies", ->
- fs.readFile "package.json", "utf8", (err, package)->
+ fs.readFile "package.json", "utf8", (err, pkg)->
log "Need runtime dependencies, installing into node_modules ...", green
exec "npm bundle", onerror
log "Need development dependencies, installing ...", green
- for name, version of JSON.parse(package).devDependencies
+ for name, version of JSON.parse(pkg).devDependencies
log "Installing #{name} #{version}", green
exec "npm bundle install \"#{name}@#{version}\"", onerror
View
4 package.json
@@ -30,9 +30,7 @@
"build": "cake build",
"test": "cake test"
},
- "engines": {
- "node": "0.4.x"
- },
+ "engines": "node >= 0.4.1",
"dependencies": {
"base64": "~2.0.0",
"csv": "~0.0.3"
Something went wrong with that request. Please try again.