Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Simple Puppet provider for OSX `defaults`
Ruby Puppet
Branch: master

0.1.2

latest commit ff5e33742c
@wfarr authored
Failed to load latest commit information.
manifests
.gitignore Add pkg/ dir to gitignore
Modulefile 0.1.2
README.md reimplement as a puppet-defined custom type
metadata.json initial commit

README.md

Defaults

This is a simple puppet module for managing the defaults system in OS X.

It currently has support for defaults domain keys whose values are boolean, integer, or string types.

Requirements

  • Ruby 1.8 or 1.9
  • Puppet 2.6.0 or later
  • OS X

Usage

osx_defaults { "require pass at screensaver":
  ensure => present,
  domain => 'com.apple.screensaver',
  key    => 'askForPassword',
  value  => 1,
  user   => 'dummy'
}

Contributing

  • Fork It
  • Fix It
  • Send a Pull Request
Something went wrong with that request. Please try again.