Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

dev: move dev-env gems to Gemfile-custom.sample

  • Loading branch information...
commit d67083c7e7f88adbcda87564fdda9746ff849b79 1 parent f776aca
@dchelimsky dchelimsky authored
Showing with 68 additions and 38 deletions.
  1. +28 −0 DEV-README.md
  2. +4 −38 Gemfile
  3. +36 −0 Gemfile-custom.sample
View
28 DEV-README.md
@@ -0,0 +1,28 @@
+## Set up the dev environment
+
+ git clone git://github.com/rspec/rspec-expectations.git
+ cd rspec-expectations
+ gem install bundler
+ bundle install
+
+Now you should be able to run any of:
+
+ rake
+ rake spec
+ rake cucumber
+
+Or, if you prefer to use the rspec and cucumber commands directly, you can either:
+
+ bundle exec rspec
+
+Or ...
+
+ bundle install --binstubs
+ bin/rspec
+
+## Customize the dev enviroment
+
+The Gemfile includes the gems you'll need to be able to run specs. If you want
+to customize your dev enviroment with additional tools like guard or
+ruby-debug, add any additional gem declarations to Gemfile-custom (see
+Gemfile-custom.sample for some examples).
View
42 Gemfile
@@ -11,47 +11,13 @@ source "http://rubygems.org"
end
### dev dependencies
-gem "rake", "~> 0.9"
-gem "cucumber", "1.0.0"
+gem "rake"
+gem "cucumber", "1.0.1"
gem "aruba", "0.4.2"
-gem "nokogiri", "1.4.4"
+gem "nokogiri", "1.5.0"
platforms :jruby do
gem "jruby-openssl"
end
-group :development do
- gem "rcov", "0.9.9", :platforms => :mri
- gem "relish", "~> 0.5.0"
- gem "guard-rspec", "0.1.9"
- gem "growl", "1.0.3"
-
- platforms :mri_18 do
- gem 'ruby-debug'
- end
-
- platforms :mri_19 do
- gem 'ruby-debug19', '~> 0.11.6'
- if RUBY_VERSION == '1.9.3' && !ENV['TRAVIS']
- if `gem list ruby-debug-base19` =~ /0\.11\.26/
- gem 'ruby-debug-base19', '0.11.26'
- else
- warn "Download and install ruby-debug-base19-0.11.26 from http://rubyforge.org/frs/shownotes.php?release_id=46303"
- end
-
- if `gem list linecache19` =~ /0\.5\.13/
- gem 'linecache19', '0.5.13'
- else
- warn "Download and install linecache19-0.5.13 from http://rubyforge.org/frs/download.php/75414/linecache19-0.5.13.gem"
- end
- else
- gem 'ruby-debug-base19', '~> 0.11.25'
- gem 'linecache19', '~> 0.5.12'
- end
- end
-
- platforms :mri_18, :mri_19 do
- gem "rb-fsevent", "~> 0.3.9"
- gem "ruby-prof", "~> 0.9.2"
- end
-end
+eval File.read('Gemfile-custom') if File.exist?('Gemfile-custom')
View
36 Gemfile-custom.sample
@@ -0,0 +1,36 @@
+group :development do
+ gem 'interactive_rspec'
+ gem 'yard'
+ gem "relish", "~> 0.5.0"
+ gem "guard-rspec", "0.5.0"
+ gem "growl", "1.0.3"
+ gem "spork", "0.9.0.rc9"
+
+ platforms :mri_18, :jruby do
+ gem "rcov", "0.9.10"
+ end
+
+ platforms :mri_18 do
+ gem 'ruby-debug'
+ end
+
+ platforms :mri_19 do
+ case RUBY_VERSION
+ when '1.9.2'
+ gem 'ruby-debug19', '0.11.6'
+ gem 'ruby-debug-base19', '0.11.25'
+ gem 'linecache19', '0.5.12'
+ when '1.9.3'
+ # NOTE - see http://blog.wyeworks.com/2011/11/1/ruby-1-9-3-and-ruby-debug
+ # for help setting up ruby-debug19 on ruby 1.9.3
+ gem 'ruby-debug19', '0.11.6'
+ gem 'ruby-debug-base19', '0.11.26'
+ gem 'linecache19', '0.5.13'
+ end
+ end
+
+ platforms :mri_18, :mri_19 do
+ gem "rb-fsevent", "~> 0.4.3.1"
+ gem "ruby-prof", "~> 0.10.0"
+ end
+end
Please sign in to comment.
Something went wrong with that request. Please try again.