Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Version 8 pulls in an old version of babel-runtime, resulting in core-js old version #476

Closed
waynebrantley opened this issue Nov 28, 2019 · 3 comments

Comments

@waynebrantley
Copy link

@waynebrantley waynebrantley commented Nov 28, 2019

Here is the dependency tree. As you can see your main project uses current version of core-js, but the runtime uses old one.

├─┬ fetch-mock@8.0.0
│ ├─┬ babel-runtime@6.26.0
│ │ └── core-js@2.6.10
│ └── core-js@3.4.5

Could upgrade the babel-runtime...or do you have to take dependencies on these - just let users of package polyfill as needed?

@wheresrhys

This comment has been minimized.

Copy link
Owner

@wheresrhys wheresrhys commented Nov 28, 2019

Does this cause anything to break for you?

I agree it's a bit messy, and wish I'd noticed this wen releasing v7, but if nothing's actually broken, think I'll leave it be for now

@waynebrantley

This comment has been minimized.

Copy link
Author

@waynebrantley waynebrantley commented Nov 29, 2019

Unsure if it is an issue - causes warnings on npm install and thought you would want to know. As far as I know, it is not an issue, just thought you would want to cleanup.....maybe next version?

Best to remove the dependency completely - why do you specifically need/use it?

@wheresrhys

This comment has been minimized.

Copy link
Owner

@wheresrhys wheresrhys commented Dec 4, 2019

There to support one of the many weird and wonderful setups people have. If you search the issues you'll find lots of mentions of babel & core-js

I'm kicking myself for not tidying up before the v8 release (which was very recent), but I can live with it for now.

@wheresrhys wheresrhys closed this Dec 4, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.