Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Updated the gemspec using latest Bundler #6

Merged
merged 2 commits into from

2 participants

@postmodern
  • Split git ls-files using $/ for Windows.
  • Only call git ls-files once.
  • Require Ruby >= 1.9.1, since we're using require_relative.
@whitequark whitequark commented on the diff
furnace-swf.gemspec
@@ -13,11 +13,13 @@ Gem::Specification.new do |s|
%q{Flash SWF files. It can be used with furnace-avm2 in } <<
%q{order to achieve impressive results.}
- s.files = `git ls-files`.split("\n")
- s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
- s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.files = `git ls-files`.split($/)
+ s.executables = s.files.grep(%r{^bin/}).map{ |f| File.basename(f) }
@whitequark Owner

That's the default output of bundler gem. Is it wrong, then? Should this be fixed upstream?

@whitequark Owner

Oops, the title somehow slipped my attention. I see now.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
@whitequark whitequark commented on the diff
furnace-swf.gemspec
((10 lines not shown))
s.require_paths = ["lib"]
+ s.required_ruby_version = '>= 1.9.1'
@whitequark Owner

Aha, thanks, I did not know about this feature. Is it possible to specify minimal patchlevels for rubies? E.g. furnace-avm2 is known to crash 1.9.2-p0 and IIRC p180.

Double checked, and apparently you can specify the patch-level.

">= 1.9.2.180"
@whitequark Owner

Yeah, thanks. As I've just got a nonreproducible crash on 1.9.3-p320, I'll leave it as it is.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
@whitequark whitequark merged commit c394f6b into from
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
This page is out of date. Refresh to see the latest.
Showing with 5 additions and 3 deletions.
  1. +5 −3 furnace-swf.gemspec
View
8 furnace-swf.gemspec
@@ -13,11 +13,13 @@ Gem::Specification.new do |s|
%q{Flash SWF files. It can be used with furnace-avm2 in } <<
%q{order to achieve impressive results.}
- s.files = `git ls-files`.split("\n")
- s.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
- s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
+ s.files = `git ls-files`.split($/)
+ s.executables = s.files.grep(%r{^bin/}).map{ |f| File.basename(f) }
@whitequark Owner

That's the default output of bundler gem. Is it wrong, then? Should this be fixed upstream?

@whitequark Owner

Oops, the title somehow slipped my attention. I see now.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
+ s.test_files = s.files.grep(%r{^(test|spec|features)/})
s.require_paths = ["lib"]
+ s.required_ruby_version = '>= 1.9.1'
@whitequark Owner

Aha, thanks, I did not know about this feature. Is it possible to specify minimal patchlevels for rubies? E.g. furnace-avm2 is known to crash 1.9.2-p0 and IIRC p180.

Double checked, and apparently you can specify the patch-level.

">= 1.9.2.180"
@whitequark Owner

Yeah, thanks. As I've just got a nonreproducible crash on 1.9.3-p320, I'll leave it as it is.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
+
s.add_runtime_dependency "bindata"
s.add_runtime_dependency "trollop"
end
Something went wrong with that request. Please try again.