Generate unsafe (!) bindings for Elixir functions
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
lib
test
.gitattributes
.gitignore
.travis.yml
LICENSE
README.md
appveyor.yml
coveralls.json
mix.exs
mix.lock

README.md

Unsafe

Coverage Status Unix Build Status Windows Build Status Hex.pm Version Documentation

This library is designed at generating unsafe (!) bindings for Elixir function definitions at compile time.

The aim is to reduce the amount of duplicated code that developers have to write when supporting both safe and unsafe variants of functions. It was written to scratch a personal itch but due to the clear utility for a wider audience, it was packaged up to make it extensible as an open source project.

To install it for your project, you can pull it directly from Hex. Rather than use the version shown below, you can use the the latest version from Hex (shown at the top of this README).

def deps do
  [{:unsafe, "~> 1.0"}]
end

Documentation and examples can be found on Hexdocs as they're updated automatically alongside each release.