Fix InMethodGrid compile error in master branch #38

Closed
mocleiri opened this Issue Jun 22, 2011 · 3 comments

Projects

None yet

3 participants

@mocleiri
Member

My jenkins server fails to build the inmethod-grid plugin due to the following error:

ERROR] COMPILATION ERROR : 
[INFO] -------------------------------------------------------------
[ERROR] /var/lib/jenkins/jobs/Wicketstuff Core Java 5 Modules (wicket 1.5-SNAPSHOT)/workspace/jdk-1.5-parent/inmethod-grid-parent/inmethod-grid/src/main/java/com/inmethod/grid/DataProviderAdapter.java:[102,146] incompatible types
found   : com.inmethod.grid.datagrid.DataGrid<capture of ? extends com.inmethod.grid.IDataSource<T>,T>
required: com.inmethod.grid.datagrid.DataGrid<? extends com.inmethod.grid.IDataSource<T>,T>
[INFO] 1 error
@martin-g martin-g added a commit that referenced this issue Jun 22, 2011
@martin-g martin-g issue #38 Fix InMethodGrid compile error in master branch
Remove the generics because jdk1.5 cannot handle them.
0de7391
@martin-g
Member

It builds OK with jdk1.6 but it failed with jdk1.5.
I just removed the generics. Now there is a warning but at least it compiles.

@martin-g martin-g closed this Jun 22, 2011
@mocleiri
Member

Thanks, now everything in master compiles and is ready for the 1.5-RC5.1 upstream wicket release and our matching wicketstuff-core release.

@akiraly
Member
akiraly commented Jun 22, 2011

Hm interesting.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment