Only first article of the dump is visible #15

Open
akoehn opened this Issue Mar 15, 2010 · 1 comment

Comments

Projects
None yet
1 participant
Contributor

akoehn commented Mar 15, 2010

When doing

make WIKI_LANGUAGE="de" XML_FILES="dewiki-minimal.xml" DESTDIR=/home/arne/wikireader/image WORKDIR=/home/arne/wikireader/work index parse render combine hash install

with this xml dump: http://gist.github.com/333153

I am only able to view the first article, the second one is empty.
There is just the copyright template, which has only the general part of the url.

I tried to debug it, but was unable to find the cause. It seems like the complete text of the non-first articles are in the image, they are just not shown.

What am I doing wrong?

Contributor

akoehn commented Mar 16, 2010

Okay, I did some more tests:

Even with more articles only the first one has content. When searching for articles, all are found, but they are empty.

If I make an uncompressed dump, everything seems to be okay (all articles are included in the dump).

When looking the history, visited non-first articles appear as [first article without the first character]. in my test dump this is "oo" (from Foo), in another, bigger test dump it was "ahrheitstabelle" (from Wahrheitstabelle).

I tried to use gbd to find the cause of this problem, but I don't know how to view the contents of the wp buffer and such things.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment