Permalink
Browse files

Add dependencies to the gemfile

This lets us require only 'postmark-rails' from rails apps, instead of having to
require both postmark and postmark-rails.
  • Loading branch information...
1 parent 0e88b76 commit 7a7a03a09cede939f9b33bcf92a2b3c0775593a2 @foca foca committed Oct 19, 2010
Showing with 38 additions and 53 deletions.
  1. +4 −5 Gemfile
  2. +20 −44 Gemfile.lock
  3. +0 −3 README.rdoc
  4. +4 −0 Rakefile
  5. +10 −1 postmark-rails.gemspec
View
@@ -1,11 +1,10 @@
source "http://rubygems.org"
-gem "actionmailer"
-gem "postmark", ">= 0.9.0"
-gem "rake"
+gemspec
group :test do
- gem "ruby-debug"
+ gem "ruby-debug", :platforms => [:ruby_18]
+ gem "ruby-debug19", :platforms => [:ruby_19]
gem "rspec"
gem "jeweler"
-end
+end
View
@@ -1,72 +1,48 @@
+PATH
+ remote: .
+ specs:
+ postmark-rails (0.4.0)
+
GEM
remote: http://rubygems.org/
specs:
- abstract (1.0.0)
- actionmailer (3.0.0)
- actionpack (= 3.0.0)
- mail (~> 2.2.5)
- actionpack (3.0.0)
- activemodel (= 3.0.0)
- activesupport (= 3.0.0)
- builder (~> 2.1.2)
- erubis (~> 2.6.6)
- i18n (~> 0.4.1)
- rack (~> 1.2.1)
- rack-mount (~> 0.6.12)
- rack-test (~> 0.5.4)
- tzinfo (~> 0.3.23)
- activemodel (3.0.0)
- activesupport (= 3.0.0)
- builder (~> 2.1.2)
- i18n (~> 0.4.1)
- activesupport (3.0.0)
- builder (2.1.2)
+ archive-tar-minitar (0.5.2)
columnize (0.3.1)
- erubis (2.6.6)
- abstract (>= 1.0.0)
gemcutter (0.6.1)
git (1.2.5)
- i18n (0.4.1)
jeweler (1.4.0)
gemcutter (>= 0.1.0)
git (>= 1.2.5)
rubyforge (>= 2.0.0)
json_pure (1.4.6)
linecache (0.43)
- mail (2.2.6.1)
- activesupport (>= 2.3.6)
- mime-types
- treetop (>= 1.4.5)
- mime-types (1.16)
- polyglot (0.3.1)
- postmark (0.7.1)
- tmail
- rack (1.2.1)
- rack-mount (0.6.13)
- rack (>= 1.0.0)
- rack-test (0.5.4)
- rack (>= 1.0)
- rake (0.8.7)
+ linecache19 (0.5.11)
+ ruby_core_source (>= 0.1.4)
rspec (1.3.0)
ruby-debug (0.10.3)
columnize (>= 0.1)
ruby-debug-base (~> 0.10.3.0)
ruby-debug-base (0.10.3)
linecache (>= 0.3)
+ ruby-debug-base19 (0.11.24)
+ columnize (>= 0.3.1)
+ linecache19 (>= 0.5.11)
+ ruby_core_source (>= 0.1.4)
+ ruby-debug19 (0.11.6)
+ columnize (>= 0.3.1)
+ linecache19 (>= 0.5.11)
+ ruby-debug-base19 (>= 0.11.19)
+ ruby_core_source (0.1.4)
+ archive-tar-minitar (>= 0.5.2)
rubyforge (2.0.4)
json_pure (>= 1.1.7)
- tmail (1.2.7.1)
- treetop (1.4.8)
- polyglot (>= 0.3.1)
- tzinfo (0.3.23)
PLATFORMS
ruby
DEPENDENCIES
- actionmailer
jeweler
- postmark
- rake
+ postmark-rails!
rspec
ruby-debug
+ ruby-debug19
View
@@ -10,7 +10,6 @@ The Postmark Rails Gem is a drop-in plug-in for ActionMailer to send emails via
== Install
- sudo gem install postmark
sudo gem install postmark-rails
== Requirements
@@ -24,7 +23,6 @@ The Postmark Rails Gem is a drop-in plug-in for ActionMailer to send emails via
Add this to your Gemfile: (change version numbers if needed)
- gem 'postmark', '0.9.0'
gem 'postmark-rails', '0.4.0'
Don't forget to run "bundle install" command every time you change something in the Gemfile.
@@ -42,7 +40,6 @@ Add this to config/environment.rb:
...
- config.gem 'postmark'
config.gem 'postmark-rails'
require 'postmark-rails'
View
@@ -11,6 +11,10 @@ begin
gem.homepage = "http://postmarkapp.com"
gem.authors = ["Petyo Ivanov", "Ilya Sabanin"]
+ gem.add_dependency "actionmailer"
+ gem.add_dependency "postmark", ">= 0.9.0"
+ gem.add_dependency "rake"
+
gem.post_install_message = %q[
==================
Thanks for installing the postmark-rails gem. If you don't have an account, please sign up at http://postmarkapp.com/.
View
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Petyo Ivanov", "Ilya Sabanin"]
- s.date = %q{2010-09-16}
+ s.date = %q{2010-10-18}
s.description = %q{Use this plugin in your rails applications to send emails through the Postmark API}
s.email = %q{ilya@wildbit.com}
s.extra_rdoc_files = [
@@ -60,9 +60,18 @@ Gem::Specification.new do |s|
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<actionmailer>, [">= 0"])
+ s.add_runtime_dependency(%q<postmark>, [">= 0.9.0"])
+ s.add_runtime_dependency(%q<rake>, [">= 0"])
else
+ s.add_dependency(%q<actionmailer>, [">= 0"])
+ s.add_dependency(%q<postmark>, [">= 0.9.0"])
+ s.add_dependency(%q<rake>, [">= 0"])
end
else
+ s.add_dependency(%q<actionmailer>, [">= 0"])
+ s.add_dependency(%q<postmark>, [">= 0.9.0"])
+ s.add_dependency(%q<rake>, [">= 0"])
end
end

0 comments on commit 7a7a03a

Please sign in to comment.