Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Tree: 00ea0f6098
Fetching contributors…

Cannot retrieve contributors at this time

57 lines (39 sloc) 1.717 kB
How to install fapws?
=====================
Pre-requisit:
-------------
Libev:
- You must have libev (and the headers) installed. For some systems that means you have to install the "-dev" package.
- sources can be found here: http://software.schmorp.de/pkg/libev.html
Has been tested with Libev-3.49 on Linux(gentoo and archlinux) and FreeBSD-6.1, and with libev-3.8 on linux (archlinux and ubunto-904) and OpenBSD (4.5 and 4.6)
Python:
- Python >=2.4. This has been developped and tested on python 2.4, python 2.5 and Python 2.6.
This application has not been tested with Python-3.x
- On 64Bits machine, Python 2.4 will not work correctly.
WARNING:
To avoid conflicts with the previous version (called Fapws2), better to remove Fapws2 before installation of Fapws3.
For MacOSX users
-----------------
- Install MacPorts from http://www.macports.org/
- Run "sudo port install libev"
or
If you have homebrew build libev for multi-architecture:
$ brew edit libev
add:
ENV["CFLAGS"] = '-arch i386 -arch x86_64'
just above the line:
system "./configure", "--disable-dependency-tracking",
run
brew install libev
- than follow the Fapws3 installation process described here under
Install fapws:
--------------
- execute: python setup.py install
If libev is not found in /usr or in /usr/local, please provide the correct name by updating the following environment variables:
C_INCLUDE_PATH: for the libev headers
LD_LIBRARY_PATH: for the libev shared objects
That's it ;-).
if you have problems, do not hesitate to contact me on the mailing list: http://groups.google.com/group/fapws
(because of spams in the mailing list, your registration is required)
Have fun with Fapws3.
William
Jump to Line
Something went wrong with that request. Please try again.