babel plugin for docpad
CoffeeScript
Switch branches/tags
Nothing to show
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
src
test
.editorconfig
.gitignore
.jshintrc
.npmignore
.travis.yml
CONTRIBUTING.md
Cakefile
HISTORY.md
LICENSE.md
README.md
coffeelint.json
package.json

README.md

Babel Plugin for DocPad

Compiles es-next into es5 with babel

Convention: .js.babel

Install

docpad install babel

Common Errors

  • ERROR: require is not defined error when using ES6 import statements:
  • This is fixed easily with the docplad-plugin-browserifydocs plugin:
    • docpad install browserifydocs
    • Add this to the top of your .js.babel file :
			```
			---
			browserify: true
			---
			```
  

History

Discover the change history by heading on over to the HISTORY.md file.

Contribute

Discover how you can contribute by heading on over to the CONTRIBUTING.md file.

Backers

Maintainers

Sponsors

No sponsors yet! Will you be the first?

Gratipay donate button Flattr donate button PayPal donate button BitCoin donate button Wishlist browse button

Contributors

These amazing people have contributed code to this project:

Become a contributor!

License

Licensed under the incredibly permissive MIT license

Copyright © William Malo williammalo2@gmail.com (maloweb.com/en)