New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

nvcc.hpp(22): fatal error C1017: #50

Open
zhouliguo opened this Issue Dec 13, 2017 · 4 comments

Comments

Projects
None yet
4 participants
@zhouliguo
Copy link

zhouliguo commented Dec 13, 2017

When I use CUDA 9.1, I encountered the problem ".caffe/dependencies/libraries_v140_x64_py27_1.1.0/libraries/include/boost-1_61\boost/config/compiler/nvcc.hpp(22): fatal error C1017".
There is no this problem in CUDA 8.0.

@myy1966

This comment has been minimized.

Copy link

myy1966 commented Jan 31, 2018

boost 1.61 do not support CUDA 9.x,you can use CUDA 8.x or update boost to 1.65

@JavierRuano

This comment has been minimized.

Copy link

JavierRuano commented Mar 3, 2018

How to?
the package boost is inside the directory in all subdirectories (include, lib ...) with another packages.
i have the same problem than zhouliguo.
Perhaps it's possible create another package with this not default libraries?
Thanks.

@JavierRuano

This comment has been minimized.

Copy link

JavierRuano commented Mar 3, 2018

the another problem is when you install version boost 1.65, the system not detect

-- Boost version: 1.65 NOT FOUND
Only 1.62 < 1.65
-- Found the following Boost libraries:
-- system
-- thread
-- filesystem
-- regex
-- chrono
-- date_time
-- atomic

https://stackoverflow.com/questions/42123509/cmake-finds-boost-but-the-imported-targets-not-available-for-boost-version

@taosean

This comment has been minimized.

Copy link

taosean commented Oct 30, 2018

It seems commnet Line 22 to Line 24 in nvcc.hpp worked for me.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment