Skip to content
This repository

DEPRECATED : check this url for the new version (PHP 5.4 compatible) :

branch: master

Fetching latest commit…

Octocat-spinner-32-eaf2f5

Cannot retrieve the latest commit at this time

Octocat-spinner-32 Sniffs
Octocat-spinner-32 README.markdown
Octocat-spinner-32 ruleset.xml
README.markdown

This version is out of date. Check http://github.com/wimg/PHPCompatibility for the new version

PHP 5.3 Compatibility Coding Standard for PHP_CodeSniffer

This is a set of sniffs for PHP_CodeSniffer that checks for PHP 5.3 compatibility.

Installation

  • Install PHP_CodeSniffer with pear install PHP_CodeSniffer (PHP_CodeSniffer 1.3 or later is required). If pear installs PHP_CodeSniffer 1.2.x, use pear install PHP_CodeSniffer-alpha
  • Checkout this repository as PHP53Compatibility into the PHP/CodeSniffer/Standards directory.
  • Use the coding standard with phpcs --standard=PHP53Compatibility.

More information can be found on Wim Godden's blog.

Something went wrong with that request. Please try again.