Skip to content
This repository
branch: master

Oct 12, 2013

  1. Wim Godden

    Update README.markdown

    authored

Mar 05, 2012

  1. Wim Godden

    Merge pull request #5 from benmatselby/prefix-errors-with-version

    Prefix the error with the php version being checked for, so you can use it together with the new PHPCompatibility codesniffer standard (https://github.com/wimg/PHPCompatibility) and see which standard is generating which warning/error
    authored
  2. Ben Selby

    Prefix the error with the php version being checked for

    - This is following on from the new git repo to check for 5.4 compatibilities, so when running both standards you want it to be very clear as to which version is affected
    benmatselby authored

Jan 26, 2012

  1. Wim Godden

    Merge pull request #4 from jeffery/master

    Stop false positives on method names that are identical to removed extensions
    authored
  2. Jeffery Fernandez

    Stop false positives for object methods with the same name as removed…

    … extensions
    jeffery authored

Jan 15, 2012

  1. Wim Godden

    Merge pull request #3 from christiaan/master

    Misspelled forbidden word
    authored

Jan 12, 2012

  1. Christiaan Baartse

    Misspelled endswitch

    christiaan authored

Dec 22, 2010

  1. Wim Godden

    Updated: docblock @package

    Added: install instruction for forcing PHP_CodeSniffer 1.3
    authored
  2. Sebastian Bergmann

    Also process ini_get().

    sebastianbergmann authored
  3. Sebastian Bergmann

    Remove php.ini scanning and only process ini_set().

    sebastianbergmann authored
  4. Sebastian Bergmann

    Revert "Remove DeprecatedIniDirectivesSniff as its findings are attri…

    …buted to sourcecode file which is confusing."
    sebastianbergmann authored

Dec 21, 2010

  1. Sebastian Bergmann

    Remove DeprecatedIniDirectivesSniff as its findings are attributed to…

    … sourcecode file which is confusing:
    
        FILE: /usr/local/src/object-freezer/Object/Freezer/IdGenerator/UUID.php
        --------------------------------------------------------------------------------
        FOUND 0 ERROR(S) AFFECTING 1 LINE(S)
        --------------------------------------------------------------------------------
         1 | WARNING | The use of directive magic_quotes_gpc in your php.ini file is
           |         | discouraged
         1 | WARNING | The use of directive magic_quotes_runtime in your php.ini file
           |         | is discouraged
         1 | WARNING | The use of directive magic_quotes_sybase in your php.ini file is
           |         | discouraged
        --------------------------------------------------------------------------------
    sebastianbergmann authored
  2. Sebastian Bergmann

    Rename classes.

    sebastianbergmann authored
  3. Sebastian Bergmann

    Fix fatal error (Access level to DeprecatedFunctionsSniff:: must be p…

    …ublic (as in class ForbiddenFunctionsSniff)).
    sebastianbergmann authored
  4. Sebastian Bergmann

    - Only support PHP_CodeSniffer 1.3 (and newer).

    - Add installation instruction.
    sebastianbergmann authored

Aug 16, 2010

  1. Wim Godden

    Added: support for PHP_CodeSniffer 1.3.0 alpha

    authored

Jun 24, 2010

  1. Wim Godden

    Small mod to readme

    authored
  2. Wim Godden

    Removed incorrectly named file

    authored
  3. Wim Godden

    Initial release of PHP53Compat CodeSniffer standard

    authored
  4. Wim Godden

    first commit

    authored
Something went wrong with that request. Please try again.