PHP
Latest commit 7518fc6 Jul 19, 2017 @wimg committed on GitHub Merge pull request #482 from wimg/feature/issue-367-phpcs-3.x-compati…
…bility

PHPCS 3.x compatibility

README.md

PHP Compatibility Coding Standard for PHP_CodeSniffer

Latest Stable Version Latest Unstable Version Awesome License Flattr this git repo

Build Status Scrutinizer Code Quality Coverage Status Dependency Status

Tested Runtime Badge Not Tested Runtime Badge

This is a set of sniffs for PHP_CodeSniffer that checks for PHP version compatibility. It will allow you to analyse your code for compatibility with higher and lower versions of PHP.

PHP Version Support

The project aims to cover all PHP compatibility changes introduced since PHP 5.0 up to the latest PHP release. This is an ongoing process and coverage is not yet 100% (if, indeed, it ever could be). Progress is tracked on our Github issue tracker.

Pull requests that check for compatibility issues in PHP4 code - in particular between PHP 4 and PHP 5.0 - are very welcome as there are still situations where people need help upgrading legacy systems. However, coverage for changes introduced before PHP 5.1 will remain patchy as sniffs for this are not actively being developed at this time.

Requirements

PHP: 5.3+ PHP Codesniffer: 1.5.x, 2.x or 3.0.1+

The sniffs are designed to give the same results regardless of which PHP version you are using to run CodeSniffer. You should get reasonably consistent results independently of the PHP version used in your test environment, though for the best results it is recommended to run the sniffs on PHP 5.4 or higher.

PHP CodeSniffer 1.5.1 is required for 90% of the sniffs, PHPCS 2.6 or later is required for full support, notices may be thrown on older versions.

Thank you

Thanks to all contributors for their valuable contributions.

WPEngine

Thanks to WP Engine for their support on the PHP 7.0 sniffs.

Installation using PEAR (method 1)

Installation in Composer project (method 2)

  • Add the following lines to the require-dev section of your composer.json file.
"require-dev": {
   "squizlabs/php_codesniffer": "^2.0 || ^3.0.1",
   "wimg/php-compatibility": "*",
   "simplyadmire/composer-plugins" : "@dev"
},
"prefer-stable" : true
  • Run composer update --lock to install both phpcs and PHPCompatibility coding standard.
  • Use the coding standard with ./vendor/bin/phpcs --standard=PHPCompatibility

Installation via a git check-out to an arbitrary directory (method 3)

  • Install PHP_CodeSniffer via your preferred method (Composer, PEAR, Phar file, Git checkout).

  • Checkout the latest release from https://github.com/wimg/PHPCompatibility/releases into an arbitrary directory.

  • Add the path to the directory above the directory in which you cloned the PHPCompability repo to the PHPCS configuration using the below command.

    phpcs --config-set installed_paths /path/to/dir/above

    I.e. if you cloned the PHPCompatibility repository to the /my/custom/standards/PHPCompatibility directory, you will need to add the /my/custom/standards directory to the PHPCS installed_paths configuration variable.

    Pro-tip: Alternatively, and only if you use PHPCS version 2.6.0 or higher, you can tell PHP_CodeSniffer the path to the PHPCompatibility standard by adding the following snippet to your custom ruleset:

    <config name="installed_paths" value="/path/to/dir/above" />

Using the compatibility sniffs

  • Run the coding standard from the command-line with phpcs --standard=PHPCompatibility
  • You can specify which PHP version you want to test against by specifying --runtime-set testVersion 5.5.
  • You can also specify a range of PHP versions that your code needs to support. In this situation, compatibility issues that affect any of the PHP versions in that range will be reported: --runtime-set testVersion 5.3-5.5. You can omit one or other part of the range if you want to support everything above/below a particular version, i.e. --runtime-set testVersion 7.0- to support PHP 7 and above.

More information can be found on Wim Godden's blog.

Using a custom ruleset

Alternatively, you can add PHPCompatibility to a custom PHPCS ruleset.

<?xml version="1.0"?>
<ruleset name="Custom ruleset">
	<description>My rules for PHP_CodeSniffer</description>

	<!-- Run against the PHPCompatibility ruleset -->
	<rule ref="PHPCompatibility" />
	
	<!-- Run against a second ruleset -->
	<rule ref="PSR2" />

</ruleset>

You can also set the testVersion from within the ruleset:

	<config name="testVersion" value="5.3-5.5"/>

Other advanced options, such as changing the message type or severity of select sniffs, as described in the PHPCS Annotated ruleset wiki page are, of course, also supported.

PHPCompatibility specific options

At this moment, there is one sniff which has a property which can be set via the ruleset. More custom properties may become available in the future.

The PHPCompatibility.PHP.RemovedExtensions sniff checks for removed extensions based on the function prefix used for these extensions. This might clash with userland functions using the same function prefix.

To whitelist userland functions, you can pass a comma-delimited list of function names to the sniff.

	<!-- Whitelist the mysql_to_rfc3339() and mysql_another_function() functions. -->
	<rule ref="PHPCompatibility.PHP.RemovedExtensions">
		<properties>
			<property name="functionWhitelist" type="array" value="mysql_to_rfc3339,mysql_another_function" />
		</properties>
	</rule>

This property was added in PHPCompatibility version 7.0.1. As of PHPCompatibility version 8.0.0, this custom property is only supported in combination with PHPCS > 2.6.0 due to an upstream bug (which was fixed in PHPCS 2.6.0).

License

This code is released under the GNU Lesser General Public License (LGPL). For more information, visit http://www.gnu.org/copyleft/lesser.html