Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot navigate to localhost #128

Open
scegg opened this issue Jun 11, 2019 · 1 comment
Labels

Comments

@scegg
Copy link

@scegg scegg commented Jun 11, 2019

I'm submitting a...

  • Bug report (I searched for similar issues and did not find one)

Current behavior

While navigating to localhost site with IsPrivateNetworkClientServerCapabilityEnabled set to true, nothing happened, blank displaying with no DOMContentLoaded raised.

It's similar like set IsPrivateNetworkClientServerCapabilityEnabled to true between BeginInit and EndInit in Winform. Reported here.

Expected behavior

Works like Edge or other web browsers.

Minimal reproduction of the problem with instructions

        webView1.Navigate("http://localhost/test/");

Environment

Nuget Package(s): Microsoft.Toolkit.Wpf.UI.Controls.WebView 5.1.1

Package Version(s):

Windows 10 Build Number:

  • Insider Build (build number: 18912)

App min and target version:

  • Insider Build (18912)

Device form factor:

  • Desktop

Visual Studio

  • 2019

NetFx 4.8

Codes for test:
EdgeTest.zip

@r0x0r

This comment has been minimized.

Copy link

@r0x0r r0x0r commented Jun 22, 2019

As a workaround you can execute this command as an administrator. This will allow EdgeHTML to access localhost URLs.

checknetisolation LoopbackExempt -a -n="Microsoft.Win32WebViewHost_cw5n1h2txyewy"

The program needs to be run only once. It is a clutch, but I so far have not found a better solution.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.