Permalink
Browse files

Ruby関連の設定をEliからコピー

ぅ絵里ちゃん!
  • Loading branch information...
1 parent ec58cfb commit a152c3c68691d21e0b7ae5c4e2d59bfe7658402c @windyakin committed Nov 10, 2015
Showing with 43 additions and 4 deletions.
  1. +6 −0 .gitignore
  2. +1 −0 .ruby-version
  3. +18 −4 .travis.yml
  4. +4 −0 Gemfile
  5. +13 −0 Gemfile.lock
  6. +1 −0 Gruntfile.js
View
@@ -22,6 +22,12 @@ node_modules/
*.css.map
#=============================================
+# Ruby/Bundler
+#=============================================
+.bundle/
+vendor/bundle/
+
+#=============================================
# Sublime Text
#=============================================
*.sublime-workspace
View
@@ -0,0 +1 @@
+2.2.3
View
@@ -1,15 +1,29 @@
language: node_js
+
node_js:
-- '0.12'
+ - '4.2'
sudo: false
-cache: node_modules
+
+cache:
+ directories:
+ - node_modules
+ - vendor/bundle
git:
submodules: false
before_install:
-- gem install sass
+ - rvm install 2.2.3
+ - rvm use 2.2.3 --fuzzy
+ - export GEMDIR=$(rvm gemdir)
+ - ruby --version
+ - gem --version
+ - gem install bundler --quiet --no-ri --no-rdoc
+ - bundle --version
+ - bundle install --without documentation --path vendor/bundle
+ - npm install -g grunt-cli
+ - grunt --version
script:
-- npm start
+ - npm start
View
@@ -0,0 +1,4 @@
+# Pull gems from RubyGems
+source 'https://rubygems.org'
+
+gem 'sass', '~> 3.4.19'
View
@@ -0,0 +1,13 @@
+GEM
+ remote: https://rubygems.org/
+ specs:
+ sass (3.4.19)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ sass (~> 3.4.19)
+
+BUNDLED WITH
+ 1.10.6
View
@@ -47,6 +47,7 @@ module.exports = function(grunt) {
sourcemap: 'none',
unixNewlines: true,
style: 'expanded',
+ bundleExec: true,
loadPath: ['bower_components/bootstrap-sass-official/assets/stylesheets/']
},
bootstrap: {

0 comments on commit a152c3c

Please sign in to comment.