undefined method `devise' #38

Open
kbaum opened this Issue Oct 19, 2011 · 0 comments

Projects

None yet

1 participant

@kbaum
kbaum commented Oct 19, 2011

I am getting the following error when trying to run migrate for the first time.

undefined method `devise' for #<Class:0x00000102d10f30>
/Users/karl/.rvm/gems/ruby-1.9.2-p290@viewthespace/gems/activerecord-3.1.0/lib/active_record/base.rb:1082:in `method_missing'
/Users/karl/workspace/viewthespace/app/models/user.rb:4:in `<class:User>'
/Users/karl/workspace/viewthespace/app/models/user.rb:1:in `<top (required)>'
/Users/karl/.rvm/gems/ruby-1.9.2-p290@viewthespace/gems/activesupport-3.1.0/lib/active_support/dependencies.rb:456:in `load'
/Users/karl/.rvm/gems/ruby-1.9.2-p290@viewthespace/gems/activesupport-3.1.0/lib/active_support/dependencies.rb:456:in `block in load_file'
/Users/karl/.rvm/gems/ruby-1.9.2-p290@viewthespace/gems/activesupport-3.1.0/lib/active_support/dependencies.rb:640:in `new_constants_in'
/Users/karl/.rvm/gems/ruby-1.9.2-p290@viewthespace/gems/activesupport-3.1.0/lib/active_support/dependencies.rb:455:in `load_file'
/Users/karl/.rvm/gems/ruby-1.9.2-p290@viewthespace/gems/activesupport-3.1.0/lib/active_support/dependencies.rb:342:in `require_or_load'
/Users/karl/.rvm/gems/ruby-1.9.2-p290@viewthespace/gems/activesupport-3.1.0/lib/active_support/dependencies.rb:489:in `load_missing_constant'
/Users/karl/.rvm/gems/ruby-1.9.2-p290@viewthespace/gems/activesupport-3.1.0/lib/active_support/dependencies.rb:181:in `block in const_missing'
/Users/karl/.rvm/gems/ruby-1.9.2-p290@viewthespace/gems/activesupport-3.1.0/lib/active_support/dependencies.rb:179:in `each'
/Users/karl/.rvm/gems/ruby-1.9.2-p290@viewthespace/gems/activesupport-3.1.0/lib/active_support/dependencies.rb:179:in `const_missing'

I think this issue was already raised as issue #21, but for some reason github gives a 404.

I am using ruby 1.9.2 with rails 3.1.

thx!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment