New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Videos files (mp4, ogv, webm) seems to be corrupted by filtering #362

Closed
ameurenand opened this Issue Oct 14, 2014 · 5 comments

Comments

Projects
None yet
2 participants
@ameurenand

Hello,

I don't manage to use HTML5 videos with my wisdom server.
I tried several formats:

  • MP4
<video controls>
    <source src="/assets/videos/big_buck_bunny.mp4" type="video/mp4">
    <p>Your browser does not support H.264/MP4.</p>
</video>
  • Ogg
<video controls>
    <source src="/assets/videos/big_buck_bunny.ogv" type="video/ogg" />
    <p>Your browser does not support Ogg.</p>
</video>
  • WebM
<video controls>
    <source src="/assets/videos/big_buck_bunny.webm" type="video/webm">
    <p>Your browser does not support WebM.</p>
</video>

In each case, the player is displayed but it can't play the video.
After further investigation, wisdom seems to corrupt my video files during filtering
and I found an array named NON_FILTERED_EXTENSIONS but it doesn't contain my video file extension.
Could you please handle these video formats?
Thanks for you help.

@cescoffier

This comment has been minimized.

Show comment
Hide comment
@cescoffier

cescoffier Oct 14, 2014

Member

You are absolutely right!
Do you have the list of extensions ?

To turn around this issue, you can define your own 'resource' element in the pom file:

<project>
 ...
 <build>
   ...
   <resources>
     <resource>
       <directory>src/main/videos</directory>
       <filtering>false</filtering>
     </resource>
   </resources>
   ...
 </build>
 ...
</project>
Member

cescoffier commented Oct 14, 2014

You are absolutely right!
Do you have the list of extensions ?

To turn around this issue, you can define your own 'resource' element in the pom file:

<project>
 ...
 <build>
   ...
   <resources>
     <resource>
       <directory>src/main/videos</directory>
       <filtering>false</filtering>
     </resource>
   </resources>
   ...
 </build>
 ...
</project>
@ameurenand

This comment has been minimized.

Show comment
Hide comment
@ameurenand

ameurenand Oct 14, 2014

Thanks for your answer and your workaround!

Could you please add at least these 3 extensions:
"mp4"
"ogv"
"webm"

Thanks for your answer and your workaround!

Could you please add at least these 3 extensions:
"mp4"
"ogv"
"webm"

@cescoffier

This comment has been minimized.

Show comment
Hide comment
@cescoffier

cescoffier Oct 14, 2014

Member

We should probably add: "avi", "mkv" too.

Member

cescoffier commented Oct 14, 2014

We should probably add: "avi", "mkv" too.

@ameurenand

This comment has been minimized.

Show comment
Hide comment
@ameurenand

ameurenand Oct 14, 2014

Both are already in the NON_FILTERED_EXTENSIONS array.

Both are already in the NON_FILTERED_EXTENSIONS array.

@cescoffier

This comment has been minimized.

Show comment
Hide comment
@cescoffier

cescoffier Oct 14, 2014

Member

Done, Thanks !

Member

cescoffier commented Oct 14, 2014

Done, Thanks !

@cescoffier cescoffier added this to the 0.7 milestone Oct 25, 2014

@cescoffier cescoffier self-assigned this Oct 25, 2014

@cescoffier cescoffier modified the milestones: 0.7, 0.6.5 Nov 5, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment