Only one Blackbox test can require the probe bundle #450

Closed
cescoffier opened this Issue Mar 4, 2015 · 2 comments

Comments

Projects
None yet
2 participants
@cescoffier
Member

cescoffier commented Mar 4, 2015

The way we install and uninstall the probe (i.e. test bundle) in blackbox test does not work.

@cescoffier cescoffier added the bug label Mar 4, 2015

@cescoffier cescoffier self-assigned this Mar 4, 2015

@cescoffier cescoffier added this to the 0.7.1 milestone Mar 4, 2015

@cescoffier cescoffier closed this in 166e471 Mar 8, 2015

@cescoffier

This comment has been minimized.

Show comment
Hide comment
@cescoffier

cescoffier Mar 8, 2015

Member

Unfortunately, the previous way to deploy the test/probe bundle was quite broken.

I've provided a new way, incompatible.

In your test classes, add:

    @BeforeClass
    public static void init() throws BundleException {
        installTestBundle();
    }

    @AfterClass
    public static void cleanup() throws BundleException {
        removeTestBundle();
    }

instead of the deployTestBundle() method (that has disappeared).

Member

cescoffier commented Mar 8, 2015

Unfortunately, the previous way to deploy the test/probe bundle was quite broken.

I've provided a new way, incompatible.

In your test classes, add:

    @BeforeClass
    public static void init() throws BundleException {
        installTestBundle();
    }

    @AfterClass
    public static void cleanup() throws BundleException {
        removeTestBundle();
    }

instead of the deployTestBundle() method (that has disappeared).

@agonist

This comment has been minimized.

Show comment
Hide comment
@agonist

agonist Mar 8, 2015

Okay good to now thank's for the quick fix. I'll try it after the release

agonist commented Mar 8, 2015

Okay good to now thank's for the quick fix. I'll try it after the release

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment