Build failure since recent commit #87

Closed
TomRouillard opened this Issue Mar 5, 2014 · 10 comments

Comments

Projects
None yet
2 participants
@TomRouillard

I can't build wisdom anymore, but it worked fine last week,

I'm working on Windows 8, and here is the output:

[WARNING]
[WARNING] events.js:72
[WARNING] throw er; // Unhandled 'error' event
[WARNING] ^
[WARNING] Error: spawn ENOENT
[WARNING] at errnoException (child_process.js:988:11)
[WARNING] at Process.ChildProcess._handle.onexit (child_process.js:779:34)
[WARNING]
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2:07.514s
[INFO] Finished at: Wed Mar 05 15:01:38 CET 2014
[INFO] Final Memory: 14M/132M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.wisdom-framework:wisdom-maven-plugin:1.0-SNAP
SHOT:optimize-images (default-optimize-images) on project app.server.core: Error
during the execution of the NPM optipng-bin: Process exited with an error: 8 (E
xit value: 8) -> [Help 1]

@cescoffier

This comment has been minimized.

Show comment
Hide comment
@cescoffier

cescoffier Mar 5, 2014

Member

Yes, I’m aware of it….
Looking at it tonight, probably will remove my integration of optipng.

Clement

On 5 mars 2014, at 15:14, TomDigitale notifications@github.com wrote:

I can't build wisdom anymore, but it worked fine last week,

I'm working on Windows 8, and here is the output:

[WARNING]
[WARNING] events.js:72
[WARNING] throw er; // Unhandled 'error' event
[WARNING] ^
[WARNING] Error: spawn ENOENT
[WARNING] at errnoException (child_process.js:988:11)
[WARNING] at Process.ChildProcess.handle.onexit (childprocess.js:779:34)
[WARNING]
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2:07.514s
[INFO] Finished at: Wed Mar 05 15:01:38 CET 2014
[INFO] Final Memory: 14M/132M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.wisdom-framework:wisdom-maven-plugin:1.0-SNAP
SHOT:optimize-images (default-optimize-images) on project app.server.core: Error
during the execution of the NPM optipng-bin: Process exited with an error: 8 (E
xit value: 8) -> [Help 1]


Reply to this email directly or view it on GitHub.

Member

cescoffier commented Mar 5, 2014

Yes, I’m aware of it….
Looking at it tonight, probably will remove my integration of optipng.

Clement

On 5 mars 2014, at 15:14, TomDigitale notifications@github.com wrote:

I can't build wisdom anymore, but it worked fine last week,

I'm working on Windows 8, and here is the output:

[WARNING]
[WARNING] events.js:72
[WARNING] throw er; // Unhandled 'error' event
[WARNING] ^
[WARNING] Error: spawn ENOENT
[WARNING] at errnoException (child_process.js:988:11)
[WARNING] at Process.ChildProcess.handle.onexit (childprocess.js:779:34)
[WARNING]
[INFO]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2:07.514s
[INFO] Finished at: Wed Mar 05 15:01:38 CET 2014
[INFO] Final Memory: 14M/132M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.wisdom-framework:wisdom-maven-plugin:1.0-SNAP
SHOT:optimize-images (default-optimize-images) on project app.server.core: Error
during the execution of the NPM optipng-bin: Process exited with an error: 8 (E
xit value: 8) -> [Help 1]


Reply to this email directly or view it on GitHub.

@cescoffier cescoffier closed this in 111a230 Mar 5, 2014

@cescoffier

This comment has been minimized.

Show comment
Hide comment
@cescoffier

cescoffier Mar 5, 2014

Member

@TomDigitale @jenf11 I've change how are provisioned optipng and jpegtran, could you try ?

Member

cescoffier commented Mar 5, 2014

@TomDigitale @jenf11 I've change how are provisioned optipng and jpegtran, could you try ?

@TomRouillard

This comment has been minimized.

Show comment
Hide comment
@TomRouillard

TomRouillard Mar 6, 2014

Still not working, here is the new error (there is more than that, tell me if you want the full output) :

[INFO] Downloading jpegtran from {jpegtran.exe=https://raw.github.com/yeoman/nod
e-jpegtran-bin/master/vendor/win/x64/jpegtran.exe, libjpeg-62.dll=https://raw.gi
thub.com/yeoman/node-jpegtran-bin/master/vendor/win/x64/libjpeg-62.dll}
[ERROR] Cannot download jpegtran from {jpegtran.exe=https://raw.github.com/yeoma
n/node-jpegtran-bin/master/vendor/win/x64/jpegtran.exe, libjpeg-62.dll=https://r
aw.github.com/yeoman/node-jpegtran-bin/master/vendor/win/x64/libjpeg-62.dll}
java.io.IOException: Directory 'C:\Users\tom_000.wisdom\utils\https:\raw.github
.com\yeoman\node-jpegtran-bin\master\vendor\win\x64' could not be created

....

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 34.724s
[INFO] Finished at: Thu Mar 06 10:53:24 CET 2014
[INFO] Final Memory: 15M/145M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.wisdom-framework:wisdom-maven-plugin:1.0-SNAP
SHOT:optimize-images (default-optimize-images) on project app.server.core: Execu
tion default-optimize-images of goal org.wisdom-framework:wisdom-maven-plugin:1.
0-SNAPSHOT:optimize-images failed. NullPointerException -> [Help 1]
[ERROR]

Still not working, here is the new error (there is more than that, tell me if you want the full output) :

[INFO] Downloading jpegtran from {jpegtran.exe=https://raw.github.com/yeoman/nod
e-jpegtran-bin/master/vendor/win/x64/jpegtran.exe, libjpeg-62.dll=https://raw.gi
thub.com/yeoman/node-jpegtran-bin/master/vendor/win/x64/libjpeg-62.dll}
[ERROR] Cannot download jpegtran from {jpegtran.exe=https://raw.github.com/yeoma
n/node-jpegtran-bin/master/vendor/win/x64/jpegtran.exe, libjpeg-62.dll=https://r
aw.github.com/yeoman/node-jpegtran-bin/master/vendor/win/x64/libjpeg-62.dll}
java.io.IOException: Directory 'C:\Users\tom_000.wisdom\utils\https:\raw.github
.com\yeoman\node-jpegtran-bin\master\vendor\win\x64' could not be created

....

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 34.724s
[INFO] Finished at: Thu Mar 06 10:53:24 CET 2014
[INFO] Final Memory: 15M/145M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.wisdom-framework:wisdom-maven-plugin:1.0-SNAP
SHOT:optimize-images (default-optimize-images) on project app.server.core: Execu
tion default-optimize-images of goal org.wisdom-framework:wisdom-maven-plugin:1.
0-SNAPSHOT:optimize-images failed. NullPointerException -> [Help 1]
[ERROR]

@cescoffier

This comment has been minimized.

Show comment
Hide comment
@cescoffier

cescoffier Mar 6, 2014

Member

Oh, that’s a bug on windows. Gonna try right now in virtual box.

On 6 mars 2014, at 11:34, TomDigitale notifications@github.com wrote:

Still not working, here is the new error (there is more than that, tell me if you want the full output) :

[INFO] Downloading jpegtran from {jpegtran.exe=https://raw.github.com/yeoman/nod
e-jpegtran-bin/master/vendor/win/x64/jpegtran.exe, libjpeg-62.dll=https://raw.gi
thub.com/yeoman/node-jpegtran-bin/master/vendor/win/x64/libjpeg-62.dll}
[ERROR] Cannot download jpegtran from {jpegtran.exe=https://raw.github.com/yeoma
n/node-jpegtran-bin/master/vendor/win/x64/jpegtran.exe, libjpeg-62.dll=https://r
aw.github.com/yeoman/node-jpegtran-bin/master/vendor/win/x64/libjpeg-62.dll}
java.io.IOException: Directory 'C:\Users\tom_000.wisdom\utils\https:\raw.github
.com\yeoman\node-jpegtran-bin\master\vendor\win\x64' could not be created

....

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 34.724s
[INFO] Finished at: Thu Mar 06 10:53:24 CET 2014
[INFO] Final Memory: 15M/145M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.wisdom-framework:wisdom-maven-plugin:1.0-SNAP
SHOT:optimize-images (default-optimize-images) on project app.server.core: Execu
tion default-optimize-images of goal org.wisdom-framework:wisdom-maven-plugin:1.
0-SNAPSHOT:optimize-images failed. NullPointerException -> [Help 1]
[ERROR]


Reply to this email directly or view it on GitHub.

Member

cescoffier commented Mar 6, 2014

Oh, that’s a bug on windows. Gonna try right now in virtual box.

On 6 mars 2014, at 11:34, TomDigitale notifications@github.com wrote:

Still not working, here is the new error (there is more than that, tell me if you want the full output) :

[INFO] Downloading jpegtran from {jpegtran.exe=https://raw.github.com/yeoman/nod
e-jpegtran-bin/master/vendor/win/x64/jpegtran.exe, libjpeg-62.dll=https://raw.gi
thub.com/yeoman/node-jpegtran-bin/master/vendor/win/x64/libjpeg-62.dll}
[ERROR] Cannot download jpegtran from {jpegtran.exe=https://raw.github.com/yeoma
n/node-jpegtran-bin/master/vendor/win/x64/jpegtran.exe, libjpeg-62.dll=https://r
aw.github.com/yeoman/node-jpegtran-bin/master/vendor/win/x64/libjpeg-62.dll}
java.io.IOException: Directory 'C:\Users\tom_000.wisdom\utils\https:\raw.github
.com\yeoman\node-jpegtran-bin\master\vendor\win\x64' could not be created

....

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 34.724s
[INFO] Finished at: Thu Mar 06 10:53:24 CET 2014
[INFO] Final Memory: 15M/145M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.wisdom-framework:wisdom-maven-plugin:1.0-SNAP
SHOT:optimize-images (default-optimize-images) on project app.server.core: Execu
tion default-optimize-images of goal org.wisdom-framework:wisdom-maven-plugin:1.
0-SNAPSHOT:optimize-images failed. NullPointerException -> [Help 1]
[ERROR]


Reply to this email directly or view it on GitHub.

@cescoffier cescoffier reopened this Mar 6, 2014

@cescoffier

This comment has been minimized.

Show comment
Hide comment
@cescoffier

cescoffier Mar 6, 2014

Member

Ok, Got it. Messed up the download of jpegtran.

Could you retry ?

Member

cescoffier commented Mar 6, 2014

Ok, Got it. Messed up the download of jpegtran.

Could you retry ?

@TomRouillard

This comment has been minimized.

Show comment
Hide comment
@TomRouillard

TomRouillard Mar 6, 2014

Ok, so I've rebuild wisdom from latest sources, and its still not working, but it seems better:

[INFO] Optimizing C:\Users\tom_000(...)\images\spinner.gif
[INFO] Executing C:\Users\tom_000.wisdom\utils\optipng.exe C:\Users\tom_000(...)\images\spinner.gif
[WARNING] ** Processing: C:\Users\tom_000(...)\images\spinner.gif
[WARNING] Importing GIF (multi-image or animation)
[WARNING] 32x32 pixels, 8 bits/pixel, 16 colors in palette
[WARNING] Reducing image to 4 bits/pixel, 13 colors in palette
[WARNING] Conversion to PNG requires snipping. Rerun OptiPNG with -snip enabled.

[WARNING] Error: Incompatible input format
[WARNING]
[WARNING] ** Status report
[WARNING] 1 file(s) have been processed.
[WARNING] 1 error(s) have been encountered.
[WARNING]
[INFO]
[ERROR] Error while executing optipng.exe

...

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1:07.660s
[INFO] Finished at: Thu Mar 06 18:39:51 CET 2014
[INFO] Final Memory: 12M/151M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.wisdom-framework:wisdom-maven-plugin:1.0-SNAP
SHOT:optimize-images (default-optimize-images) on project app.server.core: Error
while executing optipng.exe: Process exited with an error: 1 (Exit value: 1) ->
[Help 1]

Ok, so I've rebuild wisdom from latest sources, and its still not working, but it seems better:

[INFO] Optimizing C:\Users\tom_000(...)\images\spinner.gif
[INFO] Executing C:\Users\tom_000.wisdom\utils\optipng.exe C:\Users\tom_000(...)\images\spinner.gif
[WARNING] ** Processing: C:\Users\tom_000(...)\images\spinner.gif
[WARNING] Importing GIF (multi-image or animation)
[WARNING] 32x32 pixels, 8 bits/pixel, 16 colors in palette
[WARNING] Reducing image to 4 bits/pixel, 13 colors in palette
[WARNING] Conversion to PNG requires snipping. Rerun OptiPNG with -snip enabled.

[WARNING] Error: Incompatible input format
[WARNING]
[WARNING] ** Status report
[WARNING] 1 file(s) have been processed.
[WARNING] 1 error(s) have been encountered.
[WARNING]
[INFO]
[ERROR] Error while executing optipng.exe

...

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1:07.660s
[INFO] Finished at: Thu Mar 06 18:39:51 CET 2014
[INFO] Final Memory: 12M/151M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.wisdom-framework:wisdom-maven-plugin:1.0-SNAP
SHOT:optimize-images (default-optimize-images) on project app.server.core: Error
while executing optipng.exe: Process exited with an error: 1 (Exit value: 1) ->
[Help 1]

@cescoffier

This comment has been minimized.

Show comment
Hide comment
@cescoffier

cescoffier Mar 6, 2014

Member

It looks like opting is trying to convert your gif to png, which is not what I was expecting.
Will exclude gif from the optipng file format.

On 6 mars 2014, at 18:44, TomDigitale notifications@github.com wrote:

Ok, so I've rebuild wisdom from latest sources, and its still not working, but it seems better:

[INFO] Optimizing C:\Users\tom_000(...)\images\spinner.gif
[INFO] Executing C:\Users\tom_000.wisdom\utils\optipng.exe C:\Users\tom_000(...)\images\spinner.gif
[WARNING] ** Processing: C:\Users\tom_000(...)\images\spinner.gif
[WARNING] Importing GIF (multi-image or animation)
[WARNING] 32x32 pixels, 8 bits/pixel, 16 colors in palette
[WARNING] Reducing image to 4 bits/pixel, 13 colors in palette
[WARNING] Conversion to PNG requires snipping. Rerun OptiPNG with -snip enabled.

[WARNING] Error: Incompatible input format
[WARNING]
[WARNING] ** Status report
[WARNING] 1 file(s) have been processed.
[WARNING] 1 error(s) have been encountered.
[WARNING]
[INFO]
[ERROR] Error while executing optipng.exe

...

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1:07.660s
[INFO] Finished at: Thu Mar 06 18:39:51 CET 2014
[INFO] Final Memory: 12M/151M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.wisdom-framework:wisdom-maven-plugin:1.0-SNAP
SHOT:optimize-images (default-optimize-images) on project app.server.core: Error
while executing optipng.exe: Process exited with an error: 1 (Exit value: 1) ->
[Help 1]


Reply to this email directly or view it on GitHub.

Member

cescoffier commented Mar 6, 2014

It looks like opting is trying to convert your gif to png, which is not what I was expecting.
Will exclude gif from the optipng file format.

On 6 mars 2014, at 18:44, TomDigitale notifications@github.com wrote:

Ok, so I've rebuild wisdom from latest sources, and its still not working, but it seems better:

[INFO] Optimizing C:\Users\tom_000(...)\images\spinner.gif
[INFO] Executing C:\Users\tom_000.wisdom\utils\optipng.exe C:\Users\tom_000(...)\images\spinner.gif
[WARNING] ** Processing: C:\Users\tom_000(...)\images\spinner.gif
[WARNING] Importing GIF (multi-image or animation)
[WARNING] 32x32 pixels, 8 bits/pixel, 16 colors in palette
[WARNING] Reducing image to 4 bits/pixel, 13 colors in palette
[WARNING] Conversion to PNG requires snipping. Rerun OptiPNG with -snip enabled.

[WARNING] Error: Incompatible input format
[WARNING]
[WARNING] ** Status report
[WARNING] 1 file(s) have been processed.
[WARNING] 1 error(s) have been encountered.
[WARNING]
[INFO]
[ERROR] Error while executing optipng.exe

...

[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1:07.660s
[INFO] Finished at: Thu Mar 06 18:39:51 CET 2014
[INFO] Final Memory: 12M/151M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.wisdom-framework:wisdom-maven-plugin:1.0-SNAP
SHOT:optimize-images (default-optimize-images) on project app.server.core: Error
while executing optipng.exe: Process exited with an error: 1 (Exit value: 1) ->
[Help 1]


Reply to this email directly or view it on GitHub.

@cescoffier

This comment has been minimized.

Show comment
Hide comment
@cescoffier

cescoffier Mar 12, 2014

Member

@TomDigitale Did you retry ?

Member

cescoffier commented Mar 12, 2014

@TomDigitale Did you retry ?

@TomRouillard

This comment has been minimized.

Show comment
Hide comment
@TomRouillard

TomRouillard Mar 13, 2014

Yes sorry, it works perfectly now, thanks. But is there an option to disable optimization ? It can be very slow when you have a lot of pictures.

Yes sorry, it works perfectly now, thanks. But is there an option to disable optimization ? It can be very slow when you have a lot of pictures.

@cescoffier

This comment has been minimized.

Show comment
Hide comment
@cescoffier

cescoffier Mar 13, 2014

Member

I've opened #89, will fix it over the weekend.

Member

cescoffier commented Mar 13, 2014

I've opened #89, will fix it over the weekend.

@cescoffier cescoffier closed this Mar 13, 2014

@cescoffier cescoffier modified the milestone: 0.4.0 Apr 4, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment