Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Wix install kicked off from BootStrapper doesn't show progress bar progress.. #3783

Closed
wixbot opened this Issue Sep 27, 2012 · 5 comments

Comments

Projects
None yet
1 participant
Collaborator

wixbot commented Sep 27, 2012

I have created an Installing using Wix 3.6. I then created a bootstrapper exe to do a pre req check for .NET then kick off the main install.
When the main install pops up (full gui) and you click to Install it, the progress bar progress does not progress, it stays "blank" just the action text changing gives you an indication that it is doing something... attached are the log file from the bootstrapper and the main install...
Steve Ogilvie
sogilvie@msn.com

Originally opened by steven-oh from http://sourceforge.net/p/wix/bugs/3097/

Collaborator

wixbot commented Jan 23, 2013

Managed to create a repro even earlier. Attached BundleTest.zip contains solution with 2 projects (MSI and Bundle). When running bundle, you will see that progress bar of MSI doesn't move.
Also added video screening of the case - see screen.avi file inside the zip

Collaborator

wixbot commented Jan 23, 2013

Seeing this happen too.
My burn bundle installs .NET 4.0 Client Profile followed by a WiX 3.6 generated MSI which uses WiXUI_InstallDir for it's UI.

If you move the MSI dialog, the Burn UI behind it is updating the progress bar.
Seems like burn is still treating a package using External UI as an internal one & thus handling the progress info.

Collaborator

wixbot commented Jan 23, 2013

Please attach your bundle authoring and a screenshot of what you're seeing.

Collaborator

wixbot commented Jan 23, 2013

Happens to me to. I will try to create a reproduction testing project on this weekend.

To me it looks like bootstrapper is intercepting progress messages and thus MSI doesn't show it, if it makes sense.

Collaborator

wixbot commented Oct 7, 2013

This is fixed in recent WiX v3.8 builds.

Originally posted by robmen
Area changed from Wix install kicked off from BootStrapper doesn't show progress bar progress... to
Resolutionset tofixed
Statuschanged fromUntriagedtoResolved

@wixbot wixbot added the bug label Dec 20, 2015

@wixbot wixbot added this to the v3.8 milestone Dec 20, 2015

@wixbot wixbot closed this Dec 20, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment