New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ParallelCache causes wrong status in UI #3822

Closed
wixbot opened this Issue Oct 31, 2012 · 3 comments

Comments

Projects
None yet
1 participant
@wixbot
Collaborator

wixbot commented Oct 31, 2012

If you set ParallelCache="yes" then during a repair it causes the UI to display the wrong item as being processed. So if you have .NET 4.0 + several MSIs in your package, the UI will display that it is processing the last MSI in your chain but it is actual processing .NET 4.0. (Using .NET 4.0 as an example but I think it would happen with any long running package, msi or exe.)

I think this also affects the UI during install but it is not so obvious.

Originally opened by nsleigh from http://sourceforge.net/p/wix/bugs/3128/

@wixbot

This comment has been minimized.

Collaborator

wixbot commented Apr 7, 2013

I believe this was fixed in a recent build.

@wixbot

This comment has been minimized.

Collaborator

wixbot commented Apr 7, 2013

Yes WixStdBA - should have been more specific.

@wixbot

This comment has been minimized.

Collaborator

wixbot commented Apr 7, 2013

By "the UI," are you talking about WixStdBA?

@wixbot wixbot added bug burn labels Dec 20, 2015

@wixbot wixbot added this to the v3.8 milestone Dec 20, 2015

@wixbot wixbot closed this Dec 20, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment