No way to pass arguments to LaunchTarget #3905

Closed
wixbot opened this Issue Jan 31, 2013 · 2 comments

Comments

Projects
None yet
1 participant
@wixbot
Collaborator

wixbot commented Jan 31, 2013

I was trying to specify LaunchTarget as follows:

bal:WixStandardBootstrapperApplication
LogoFile="Logo.png"
LaunchTarget="[SystemFolder]control.exe /name MyControlPanelApplet"
LicenseFile="License_English.rtf"
SuppressOptionsUI="yes"

But it doesn't work when I hit "Launch" at the end of installation.
Installation log contains this line:
Error 0x80070002: Failed to launch target: C:\Windows\system32\control.exe /name MyControlPanelApplet

Originally opened by zepilot from http://sourceforge.net/p/wix/bugs/3201/

@wixbot

This comment has been minimized.

Show comment
Hide comment
@wixbot

wixbot Apr 8, 2013

Collaborator

This is supported now.

Collaborator

wixbot commented Apr 8, 2013

This is supported now.

@wixbot

This comment has been minimized.

Show comment
Hide comment
@wixbot

wixbot Apr 8, 2013

Collaborator

That's interesting that you were able to get the /name to show up. I noticed that no matter what I did the / would always get erased out or converted to \

Collaborator

wixbot commented Apr 8, 2013

That's interesting that you were able to get the /name to show up. I noticed that no matter what I did the / would always get erased out or converted to \

@wixbot wixbot added the bug label Dec 20, 2015

@wixbot wixbot added this to the v3.8 milestone Dec 20, 2015

@wixbot wixbot closed this Dec 20, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment