Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Insignia uses invalid identifiers for digital certificates #4056

Closed
wixbot opened this Issue Jul 8, 2013 · 5 comments

Comments

Projects
None yet
2 participants
Collaborator

wixbot commented Jul 8, 2013

Insignia.exe uses the certificates thumbprint as the identifier in the MsiDigitalCertificate table. The thumbprint may start with a digit, which is not a valid identifier.

Originally opened by creativbox from http://sourceforge.net/p/wix/bugs/3341/

Collaborator

wixbot commented Jul 9, 2013

I can confirm the existence of the bug. After using insignia, ICE validation fails (I have a cert with a hash which begins with a digit).

My suggestion would be to use a standard prefix like "cer" for any auto-generated identifiers.

Collaborator

wixbot commented Aug 27, 2013

Rob,
if possible I'd like to use these as an example for Triage this week.

Originally posted by jchoover

Collaborator

wixbot commented Aug 29, 2013

Originally changed by barnson
Area set to compiler
Release changed from v4.0 to v3.8

Collaborator

wixbot commented Aug 29, 2013

Originally changed by jchoover
AssignedTo set to jchoover

Collaborator

wixbot commented Sep 19, 2013

Originally changed by jchoover
Resolution set to fixed
Status changed from Open to Resolved

@wixbot wixbot added this to the v3.8 milestone Dec 20, 2015

@wixbot wixbot closed this Dec 20, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment