Melt.exe exception when decompiling MSI and WIXPDB files #4168

Closed
wixbot opened this Issue Oct 28, 2013 · 2 comments

Comments

Projects
None yet
2 participants
@wixbot
Collaborator

wixbot commented Oct 28, 2013

Workaround: Copy *.dll from SDK folder to BIN folder :)

Command:
melt.exe "V1.0.msi" -out ".\RTM.wixpdb" -pdb "V1.0.wixpdb" -x .\RMTBinaries Windows Installer Xml Melter version 3.7.1224.0 Copyright (C) Outercurve Foundation. All rights reserved.

Output:
melt.exe : error MELT0001 : Could not load file or assembly 'Microsoft.Deployment.WindowsInstaller.Package, Version=3.0.0.0, Culture=neutral, PublicKeyToken=ce35f76fcda82bad' or one of its dependencies. The system cannot find the file specified
fied.
melt.exe : error MELT0001 : Could not load file or assembly 'Microsoft.Deployment.Compression, Version=3.0.0.0, Culture=neutral, PublicKeyToken=ce35f76fcda82bad ' or one of its dependencies. The system cannot find the file specified.

Exception Type: System.IO.FileNotFoundException

Stack Trace:
at Microsoft.Tools.WindowsInstallerXml.Tools.Melt.MeltProduct()
at Microsoft.Tools.WindowsInstallerXml.Tools.Melt.Run(String[] args)

After copying those two files I got more exceptions so I just copied ALL libraries to the bin folder and it started working.

Originally opened by scubasteve

@wixbot

This comment has been minimized.

Show comment
Hide comment
@wixbot

wixbot Oct 29, 2013

Collaborator

Needs more DTF assemblies in bin.

Originally posted by barnson
Area set to installer
AssignedTo set to bobarnson

Collaborator

wixbot commented Oct 29, 2013

Needs more DTF assemblies in bin.

Originally posted by barnson
Area set to installer
AssignedTo set to bobarnson

@wixbot

This comment has been minimized.

Show comment
Hide comment
@wixbot

wixbot Oct 31, 2013

Collaborator

Added necessary DTF assemblies.

Originally posted by barnson
Resolution set to fixed
Status changed from Open to Resolved

Collaborator

wixbot commented Oct 31, 2013

Added necessary DTF assemblies.

Originally posted by barnson
Resolution set to fixed
Status changed from Open to Resolved

@wixbot wixbot added this to the v3.8 milestone Dec 20, 2015

@wixbot wixbot closed this Dec 20, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment