InstallPrivileges and InstallScope can specify contradicting values #4532

Closed
wixbot opened this Issue Sep 21, 2014 · 4 comments

Projects

None yet

1 participant

@wixbot
Collaborator
wixbot commented Sep 21, 2014

On Package element InstallPrivileges and InstallScope can specify contradicting values.
In which case the MSI will be marked as UAC compliant, and will not open UAC prompt.
I expect that when both attributes are specified an error should be reported.

Originally opened by nirbar

@wixbot
Collaborator
wixbot commented Sep 25, 2014

Release changed from v3.8 to v3.x

@wixbot
Collaborator
wixbot commented Jun 9, 2015

Originally changed by bmurri
AssignedTo set to wixsupport

@wixbot
Collaborator
wixbot commented Jun 9, 2015

wix3 pull request here.
wix4 pull request here.

Because 4.x isn't out yet, I simply disallow both attributes being used (as the bug requests). For 3.x, I check the values for compatibility (because there is a lot of code out there where both attributes are present) but if the values are not consistent with each other an error is returned.

Originally posted by bmurri

@wixbot
Collaborator
wixbot commented Jun 24, 2015

Fixed in v3.10 and v4.0

Originally posted by bmurri
Release changed from v3.x to v3.10
Resolution set to fixed
Status changed from Open to Resolved

@wixbot wixbot added this to the v3.10 milestone Dec 20, 2015
@wixbot wixbot closed this Dec 20, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment