Cannot specify Component/@Directory when nested under ComponentGroup with Directory specified #4727

Open
wixbot opened this Issue Mar 26, 2015 · 4 comments

Projects

None yet

1 participant

@wixbot
Collaborator
wixbot commented Mar 26, 2015

Error generated is:

The Component/@Directory attribute cannot be specified when the Component element is nested underneath a Directory element.

Even though neither the Component or ComponentGroup is nested underneath a Directory element.

Found issue when trying to specify Component/@Directory for a specific Component while not specifying for others (using default of ComponentGroup).

To workaround, I had to specify Component/@Directory for each and not ComponentGroup/@Directory.

Originally opened by gregfiske

@wixbot
Collaborator
wixbot commented Mar 31, 2015

We want a better error message in v3.x. In v4.0 we can take the expanded functionality.

AssignedTo set to jocooper
Release changed from v3.9 to v3.10

@wixbot
Collaborator
wixbot commented Apr 9, 2015

Appears to be using "IllegalAttributeWhenNested" Number="62".

Originally posted by jmcooper8654

@wixbot
Collaborator
wixbot commented Apr 9, 2015

Thinking of adding the following: If this Component is a member of a ComponentGroup where ComponentGroup/@Directory is set, then the Component/@Directory attribute should be removed.

Originally posted by jmcooper8654

@wixbot
Collaborator
wixbot commented Apr 20, 2015

Took John's doc fix for v3.x. Re-opening in v4.0.

Originally posted by barnson
AssignedTo changed from jocooper to
Releasechanged fromv3.10tov4.0

@wixbot wixbot added this to the v4.0 milestone Dec 20, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment