Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Cannot specify Component/@Directory when nested under ComponentGroup with Directory specified #4727

Open
wixbot opened this Issue Mar 26, 2015 · 4 comments

Comments

Projects
None yet
1 participant
Collaborator

wixbot commented Mar 26, 2015

Error generated is:

The Component/@Directory attribute cannot be specified when the Component element is nested underneath a Directory element.

Even though neither the Component or ComponentGroup is nested underneath a Directory element.

Found issue when trying to specify Component/@directory for a specific Component while not specifying for others (using default of ComponentGroup).

To workaround, I had to specify Component/@directory for each and not ComponentGroup/@directory.

Originally opened by gregfiske

Collaborator

wixbot commented Mar 31, 2015

We want a better error message in v3.x. In v4.0 we can take the expanded functionality.

AssignedTo set to jocooper
Release changed from v3.9 to v3.10

Collaborator

wixbot commented Apr 9, 2015

Appears to be using "IllegalAttributeWhenNested" Number="62".

Originally posted by jmcooper8654

Collaborator

wixbot commented Apr 9, 2015

Thinking of adding the following: If this Component is a member of a ComponentGroup where ComponentGroup/@directory is set, then the Component/@directory attribute should be removed.

Originally posted by jmcooper8654

Collaborator

wixbot commented Apr 20, 2015

Took John's doc fix for v3.x. Re-opening in v4.0.

Originally posted by barnson
AssignedTo changed from jocooper to
Releasechanged fromv3.10tov4.0

@wixbot wixbot added this to the v4.0 milestone Dec 20, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment