Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Bootstrapper repeats to load itself when it failed to install prerequisites #4761

Closed
wixbot opened this Issue May 14, 2015 · 4 comments

Comments

Projects
None yet
2 participants
Collaborator

wixbot commented May 14, 2015

I am using WIX3.9. WixMbaPrereqPackageId in the burn wxs file points to a exe package of my own. When the bootstrapper is launched in silent mode and the prerequisite exe package failed, the bootstrapper will not fail. It shows "The prerequisites were successfully installed" and repeat to load itself. I hope the bootstrapper will fail when the prerequisite exe package fails.

does anyone have an idea on this?

prerequisites of exe package failed. the bootstrapper application repeat to be reloaded.

Log:
[0B10:099C][2015-05-11T13:17:06]i301: Applying execute package:
SimplePrereqPackage, action: Install, path: C:\ProgramData\Package Cache\FD2754490FD9047552091A739104578EA93BD988\ThirdParty\CVInstallThirdParty\CVInstallPrereqPackages.exe,
arguments: '"C:\ProgramData\Package
Cache\FD2754490FD9047552091A739104578EA93BD988\ThirdParty\CVInstallThirdParty\CVInstallPrereqPackages.exe"
"C:\CVMedia"'
[0B10:099C][2015-05-11T13:17:06]e000: Error 0x80070001: Process returned
error: 0x1
[0B10:099C][2015-05-11T13:17:06]e000: Error 0x80070001: Failed to execute EXE package.
[08C0:0458][2015-05-11T13:17:06]e000: Error 0x80070001: Failed to configure per-machine EXE package.
[08C0:0458][2015-05-11T13:17:06]i319: Applied execute package:
SimplePrereqPackage, result: 0x80070001, restart: None
[08C0:0458][2015-05-11T13:17:06]e000: Error 0x80070001: Failed to execute EXE package.
[0B10:099C][2015-05-11T13:17:06]i330: Removed bundle dependency provider:
{c3892c68-1bd3-431f-9e9d-5019da735022}
[0B10:099C][2015-05-11T13:17:06]i352: Removing cached bundle:
{c3892c68-1bd3-431f-9e9d-5019da735022}, from path: C:\ProgramData\Package Cache{c3892c68-1bd3-431f-9e9d-5019da735022}
[08C0:0458][2015-05-11T13:17:06]i399: Apply complete, result: 0x80070001,
restart: None, ba requested restart: No
[08C0:0458][2015-05-11T13:17:06]i500: Shutting down, exit code: 0x1
[08C0:0458][2015-05-11T13:17:06]i000: The prerequisites were successfully installed. The bootstrapper application will be reloaded.

Originally opened by csun

Collaborator

wixbot commented May 15, 2015

v3.10 pull request: 248

v4.0 pull request: 132

Originally posted by rseanhall

Collaborator

wixbot commented May 19, 2015

AssignedTo set to shall

Collaborator

wixbot commented May 19, 2015

Resolution set to fixed
Status changed from Open to Resolved

Collaborator

wixbot commented May 19, 2015

Originally changed by rseanhall
Release changed from v3.9 to v3.10

@wixbot wixbot added bug burn labels Dec 20, 2015

@wixbot wixbot added this to the v3.10 milestone Dec 20, 2015

@wixbot wixbot closed this Dec 20, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment