MSI built with 3.10 fails to install on XP #4902

Closed
wixbot opened this Issue Sep 22, 2015 · 4 comments

Projects

None yet

2 participants

@wixbot
Collaborator
wixbot commented Sep 22, 2015

In both a clean install and upgrade, an MSI built with 3.10 fails with:
MSI (s) (C0:30) [19:03:41:323]: Note: 1: 2769 2: WixSchedInternetShortcuts 3: 3
DEBUG: Error 2769: Custom Action WixSchedInternetShortcuts did not close 3 MSIHANDLEs.
The installer has encountered an unexpected error installing this package. This may indicate a problem with this package. The error code is 2769. The arguments are: WixSchedInternetShortcuts, 3,
Action ended 19:03:41: WixSchedInternetShortcuts. Return value 3.

This same MSI, when built with 3.9, succeeds.

My first thought was that maybe wixca.dll was not built to target XP, but Bob Arnson did say that it is and that "actually begins to execute but crashes in what appears to be an innocuous API call."

Originally opened by dcon

@wixbot
Collaborator
wixbot commented Sep 22, 2015

AssignedTo set to bobarnson
Release changed from v3.10 to v3.11

@wixbot
Collaborator
wixbot commented Sep 29, 2015

Dev14 has a change that breaks XP compatibility even when used with v140_xp toolset. See Connect item on this very issue.

Also fixes WIXBUG:4908.

Originally posted by barnson
Status changed from Open to Untriaged

@wixbot
Collaborator
wixbot commented Sep 29, 2015

Release changed from v3.11 to v3.10

@wixbot
Collaborator
wixbot commented Oct 7, 2015

We have a release candidate of a maintenance release that fixes this bug. Please try it out and let us know how it works. You can get the release at: http://wixtoolset.org/releases/v3-10-1-2207/

Originally posted by barnson

@barnson barnson was assigned by wixbot Dec 20, 2015
@wixbot wixbot added this to the v3.10 milestone Dec 20, 2015
@barnson barnson closed this Feb 6, 2016
@rseanhall rseanhall added a commit to rseanhall/wix4 that referenced this issue Mar 19, 2016
@barnson @rseanhall barnson + rseanhall Work around Dev14 change that breaks XP compatibility
...even when used with v140_xp toolset. See [Connect item on this very issue](https://connect.microsoft.com/VisualStudio/feedback/details/1789709/visual-c-2015-runtime-broken-on-windows-server-2003-c-11-magic-statics). Fixes WIXBUG:4902 and WIXBUG:4908.

Addresses wixtoolset/issues#4902 and wixtoolset/issues#4908.
e81d783
@robmen robmen added a commit to wixtoolset/wix4 that referenced this issue Mar 22, 2016
@barnson @robmen barnson + robmen Work around Dev14 change that breaks XP compatibility
...even when used with v140_xp toolset. See [Connect item on this very issue](https://connect.microsoft.com/VisualStudio/feedback/details/1789709/visual-c-2015-runtime-broken-on-windows-server-2003-c-11-magic-statics). Fixes WIXBUG:4902 and WIXBUG:4908.

Addresses wixtoolset/issues#4902 and wixtoolset/issues#4908.
9a5d857
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment