New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ProgressDlg shows "Copying new files File: [1], Directory: [9], Size: [6]" on Windows 10 #5697

Open
eteeuw-groeneveld opened this Issue Oct 9, 2017 · 3 comments

Comments

Projects
None yet
3 participants
@eteeuw-groeneveld

eteeuw-groeneveld commented Oct 9, 2017

  • Which version of WiX are you building with?

3.11.0.1701

  • Which version of Visual Studio are you building with (if any)?

Visual Studio 2017 Professional (15.3.5)

  • Which version of the WiX Toolset Visual Studio Extension are you building with (if any)?

0.9.21.62588

  • Which version of .NET are you building with?

4.6.1

  • If the problem occurs when installing your packages built with WiX, what is the version of Windows the package is running on?

Windows 10 Enterprise 1703 x64

  • Describe the problem and the steps to reproduce it.

Create a WiX Setup project (MSI) and use the WixUI_FeatureTree dialog set. Do NOT reference the WixUI_ErrorProgressText. Run the setup on Window 8.1 or below and the ProgressDlg will show 'Copying new files' correctly. Run the setup on Windows 10 (1703?) and the ProgressDlg will show 'Copying new files File: [1], Directory: [9], Size: [6]' instead.

  • Describe the behavior you expected and how it differed from the actual behavior.

The ProgressDlg should show 'Copying new files' instead of 'Copying new files File: [1], Directory: [9], Size: [6]' on Windows 10 as well (using stock action text).

@BMurri

This comment has been minimized.

Show comment
Hide comment
@BMurri

BMurri Oct 9, 2017

Collaborator

Looks to me to be a duplicate of #5423

Collaborator

BMurri commented Oct 9, 2017

Looks to me to be a duplicate of #5423

@eteeuw-groeneveld

This comment has been minimized.

Show comment
Hide comment
@eteeuw-groeneveld

eteeuw-groeneveld Oct 9, 2017

I agree. I've searched for similar issues, but didn't this one. Why is that issue closed?

eteeuw-groeneveld commented Oct 9, 2017

I agree. I've searched for similar issues, but didn't this one. Why is that issue closed?

@barnson

This comment has been minimized.

Show comment
Hide comment
@barnson

barnson Oct 9, 2017

Member

When you don't reference WixUI_ErrorProgressText, WiX doesn't supply any strings. Windows is supplying and failing to correctly format the strings. Nothing WiX can do to influence that, other than supply the strings.

Member

barnson commented Oct 9, 2017

When you don't reference WixUI_ErrorProgressText, WiX doesn't supply any strings. Windows is supplying and failing to correctly format the strings. Nothing WiX can do to influence that, other than supply the strings.

@barnson barnson added the external label Oct 12, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment