New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

WiX v4 should use the Windows 10 SDK for all native code #5864

Open
barnson opened this Issue Aug 16, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@barnson
Copy link
Member

barnson commented Aug 16, 2018

  • Which version of WiX are you building with?

wix4 HEAD

  • Which version of Visual Studio are you building with (if any)?

15.8.0

  • Which version of the WiX Toolset Visual Studio Extension are you building with (if any)?

n/a

  • Which version of .NET are you building with?

4.7.2

  • If the problem occurs when installing your packages built with WiX, what is the version of Windows the package is running on?

n/a

  • Describe the problem and the steps to reproduce it.

Some projects use the Windows 8.1 SDK and some use a version of the Windows 10 SDK. If you don't have the 8.1 SDK installed, you can't build (e.g., VisualStudio.wixext).

  • Describe the behavior you expected and how it differed from the actual behavior.

WiX should rely on one SDK. Maybe 8.1 is the right version, if used for everything?

@barnson barnson added this to the v4.0 milestone Sep 13, 2018

@barnson barnson self-assigned this Sep 13, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment