Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

sh doesn't find installed packages. #320

Closed
GoogleCodeExporter opened this issue Mar 29, 2015 · 2 comments
Closed

sh doesn't find installed packages. #320

GoogleCodeExporter opened this issue Mar 29, 2015 · 2 comments

Comments

@GoogleCodeExporter
Copy link

@GoogleCodeExporter GoogleCodeExporter commented Mar 29, 2015

What steps will reproduce the problem?
1. install any pkg (f/e nano)
2. try to launch it (nano or /opt/bn/nano)
3. result: -sh: nano: not found

What is the expected output? What do you see instead?

It'll be not bad if nano will be launched. But, it's not found

What version of the product are you using?
[ root]$ uname -a
Linux WL-BCAEC5C3F764 2.6.22.19 #2 Mon Apr 2 21:59:34 MSK 2012 mips GNU/Linux

Please provide any additional information below.

I tried 1.9.2.7-d and 1.9.2.7-rtn for WL-500gPv2 and result is the same. 
Adjusted environment according to 
http://wl500g.info/showthread.php?10307-How-To-Install-and-Configure-Olegs-firmw
are&p=60933#post60933
My final target - install and configure SVN server on the router.

May be I do something wrong?

Answer me please, if you can.

Thanks and regards, Ivan.

Original issue reported on code.google.com by Serge...@mail.ru on 5 May 2012 at 7:34

@GoogleCodeExporter
Copy link
Author

@GoogleCodeExporter GoogleCodeExporter commented Mar 29, 2015

Hey, guys!

If you faced with the same issue, just create links to all .so from /lib to 
/opt/lib

command is "ln -s /lib/*.so /opt/lib"

For some reasons, all packages from repository use standard libs from /opt/lib 
instead /lib

Original comment by Serge...@mail.ru on 10 May 2012 at 5:32

  • Added labels: ****
  • Removed labels: ****
@GoogleCodeExporter
Copy link
Author

@GoogleCodeExporter GoogleCodeExporter commented Mar 29, 2015

We are not responsible for external software. Try to seek at wl500g.info forum.

Original comment by lly.dev on 11 May 2012 at 7:23

  • Changed state: Invalid
  • Added labels: Type-Support
  • Removed labels: Type-Defect
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant