Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Updates dependency checker for Sensei 2 and PHP 5.6+ #68

Merged
merged 3 commits into from Mar 13, 2019

Conversation

Projects
None yet
3 participants
@jom
Copy link
Contributor

commented Mar 12, 2019

Brings the work from the Content Drip PR over to Sensei Certificates: woocommerce/sensei-content-drip#146

Replaces #57
Fixes #56

Testing Instructions

  • If activated, deactivate all versions of Sensei.
  • Remove sensei_version and woothemes_sensei_version options.
  • If not active, activate this plugin on built version of this branch. Verify the Sensei dependency message shows on Plugins page and Dashboard page.
  • Activate Sensei 1.12.x. Verify message disappears.
  • Deactivate Sensei 1.12.x. Activate Sensei 2.x. Verify message is still gone.
  • Deactivate Sensei 2.x and activate Sensei with WooCommerce Paid Courses. Verify message is still gone.

Test PHP version:

  • Activate Sensei and version of this branch on PHP 5.2-5.5. Verify PHP version notice appears.

@jom jom added this to the 2.0.0 milestone Mar 12, 2019

@jom jom requested review from alexsanford and donnapep Mar 12, 2019

@alexsanford
Copy link
Contributor

left a comment

When I have Sensei with WooCommerce Paid Courses activated, but installed in an alternative directory (woothemes-sensei-compat/) I see the notice that Sensei Course Progress requires Sensei.

I'm pretty sure this is because I have it installed in a non-standard location, and the class check doesn't help because it's being run too early. Not sure whether this is something we can fix, since we need to decide early whether to load the plugin. But this means that the class check really isn't doing us a lot of good.

Otherwise, this seems to work really well! 🎸

@jom

This comment has been minimized.

Copy link
Contributor Author

commented Mar 13, 2019

@alexsanford Yup, I don't think there is anything we can do about this. Class check only helps when the alternative directory that Sensei is installed in comes before sensei.

@jom jom merged commit 0c6c3bf into master Mar 13, 2019

@jom jom deleted the update/deps-check branch Mar 13, 2019

@lkraav

This comment has been minimized.

Copy link

commented Mar 14, 2019

Yup, I don't think there is anything we can do about this. Class check only helps when the alternative directory that Sensei is installed in comes before sensei.

@jom please review woocommerce/woocommerce#21525 because WooCommerce just went through this, where things broke due to relying on specific directory loading order, etc

Dependency checks should be performed on add_action plugins_loaded. Your thoughts?

@jom

This comment has been minimized.

Copy link
Contributor Author

commented Mar 14, 2019

@lkraav It took a bit of a refactor which is why I avoided it at first, but trying it out in this PR:
woocommerce/sensei-content-drip#160

@donnapep donnapep changed the title Updates dependency checker for Sensei 2 and updated PHP requirement Updates dependency checker for Sensei 2 and PHP 5.6+ Apr 23, 2019

@matticbot matticbot referenced this pull request Apr 25, 2019

Closed

Update extensions #2539

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.