Not able to Activate WooCommerce after Install ( Manual/Automatic ). #1049

Closed
ranjprashant opened this Issue May 16, 2012 · 11 comments

Comments

Projects
None yet
5 participants
@ranjprashant

Hi This is Prashant.

I tried to install and activate wocommerce 1.5.5 in my local Computer, with MySql Version 5.5.20, MySql Version 5.3.10 and Apache version 2.2.21, both Manual and throgh direct install (WP Latest Version ).

In both scenario wocommerce 1.5.5 got installed , but when i click on Activate link .
Got Message on Browser.

"The connection was reset
The connection to the server was reset while the page was loading.
The site could be temporarily unavailable or too busy. Try again in a few moments.
If you are unable to load any pages, check your computer's network connection.
If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Please Resolve my issue.

@mikejolley

This comment has been minimized.

Show comment Hide comment
@mikejolley

mikejolley May 16, 2012

Member

We don't know whats causing this yet, we could do with getting access to FTP/WP Admin for someone with this issue. If thats possible, email the details to mike.j@woothemes.com

Member

mikejolley commented May 16, 2012

We don't know whats causing this yet, we could do with getting access to FTP/WP Admin for someone with this issue. If thats possible, email the details to mike.j@woothemes.com

@ranjprashant

This comment has been minimized.

Show comment Hide comment
@ranjprashant

ranjprashant May 17, 2012

Hi Thanks for Reply,
As i already mentioned that i'm using woocomerce in my local system and later i'll transfer to my production server. Still i'm getting the same issue, but only with woocommerce other plugins installed and activated successfully on what the settings i'm using for others in WP and PHP.

Also, when i used version 1.2.2 instead of version 1.5.5 , version 1.2.2 installed and activated successfully, so i guess there is no problem in my configuration. but not able to guess what is the problem with version 1..5.5.

Thanks annd Regards,
PRASHANT RANJAN

Hi Thanks for Reply,
As i already mentioned that i'm using woocomerce in my local system and later i'll transfer to my production server. Still i'm getting the same issue, but only with woocommerce other plugins installed and activated successfully on what the settings i'm using for others in WP and PHP.

Also, when i used version 1.2.2 instead of version 1.5.5 , version 1.2.2 installed and activated successfully, so i guess there is no problem in my configuration. but not able to guess what is the problem with version 1..5.5.

Thanks annd Regards,
PRASHANT RANJAN

@mikejolley

This comment has been minimized.

Show comment Hide comment
@mikejolley

mikejolley May 17, 2012

Member

Works on production, but not on local?

Member

mikejolley commented May 17, 2012

Works on production, but not on local?

@ranjprashant

This comment has been minimized.

Show comment Hide comment
@ranjprashant

ranjprashant May 17, 2012

Man i haven't use on production yet, only i tried in Local on Two machines, and got same error.

Man i haven't use on production yet, only i tried in Local on Two machines, and got same error.

@mikejolley

This comment has been minimized.

Show comment Hide comment
@mikejolley

mikejolley May 17, 2012

Member

Sadly I don't have access to a WAMP install to test.

Member

mikejolley commented May 17, 2012

Sadly I don't have access to a WAMP install to test.

@nodar44

This comment has been minimized.

Show comment Hide comment
@nodar44

nodar44 May 17, 2012

Contributor

Hi Prashant, I have this problem too :
http://wordpress.org/support/topic/plugin-woocommerce-%E2%80%93-excelling-ecommerce-woocommerce%E2%80%93excelling-ecommerce155-unable-to-activate-plugin-on-new-install?replies=9

I tried without any firewall/antivirus, with same result, really, I can't understand where's the problem...

Prashant, are you a windows user? 64 bits system? Wamp or EasyPHP too?

Works fine with woo 1.5.4. Mike, I would like to have a look at the changelog, is there a place to find it?

Contributor

nodar44 commented May 17, 2012

Hi Prashant, I have this problem too :
http://wordpress.org/support/topic/plugin-woocommerce-%E2%80%93-excelling-ecommerce-woocommerce%E2%80%93excelling-ecommerce155-unable-to-activate-plugin-on-new-install?replies=9

I tried without any firewall/antivirus, with same result, really, I can't understand where's the problem...

Prashant, are you a windows user? 64 bits system? Wamp or EasyPHP too?

Works fine with woo 1.5.4. Mike, I would like to have a look at the changelog, is there a place to find it?

@mikejolley

This comment has been minimized.

Show comment Hide comment
@mikejolley

mikejolley May 17, 2012

Member

Its in the wc directory - readme.

Member

mikejolley commented May 17, 2012

Its in the wc directory - readme.

@Ramoonus

This comment has been minimized.

Show comment Hide comment
@Ramoonus

Ramoonus May 17, 2012

Contributor

you have MySql Version 5.3.10 ????

Contributor

Ramoonus commented May 17, 2012

you have MySql Version 5.3.10 ????

@maxrice

This comment has been minimized.

Show comment Hide comment
@maxrice

maxrice May 17, 2012

Contributor

fixed this. I'll send a pull request. PHP has a bug in all versions up to 5.3.11, on windows, that crashes itself if a file is 4096 bytes or any multiple of that. woocommerce-core-functions.php is currently 28672 bytes, which causes this error when activating. See https://bugs.php.net/bug.php?id=61166

@ranjprashant you can fix this by adding a blank line anywhere in the file.

Contributor

maxrice commented May 17, 2012

fixed this. I'll send a pull request. PHP has a bug in all versions up to 5.3.11, on windows, that crashes itself if a file is 4096 bytes or any multiple of that. woocommerce-core-functions.php is currently 28672 bytes, which causes this error when activating. See https://bugs.php.net/bug.php?id=61166

@ranjprashant you can fix this by adding a blank line anywhere in the file.

@ranjprashant

This comment has been minimized.

Show comment Hide comment
@ranjprashant

ranjprashant May 18, 2012

Hi Maxrice,
Thanks for the solution, after adding blank line it's got activated, and working fine.

Hi Maxrice,
Thanks for the solution, after adding blank line it's got activated, and working fine.

jjoeris pushed a commit to jjoeris/woocommerce that referenced this issue May 18, 2012

@maxrice

This comment has been minimized.

Show comment Hide comment
@maxrice

maxrice May 18, 2012

Contributor

no problem!

Contributor

maxrice commented May 18, 2012

no problem!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment