New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Tax is 0 on cart and on checkout does not include shipping until billing details modified #15589

Closed
Matekk opened this Issue Jun 13, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@Matekk

Matekk commented Jun 13, 2017

Hi,

Maybe it's down to configuration but I can not solve this issue.
On the cart page the tax is displayed 0 (I have display tax as single total selected, read someplace that is the reason) then on checkout it calculates tax but without shipping costs.

Modifying billing details then recalculates taxes correctly, including shipping costs. (Modifying as in just to fire the recalculation action, entering the same values)

I haven't concluded what causes this, but it seems it's saved in cookie information, as afterwards the tax is always correctly calculated on the checkout page (cart still shows 0).

Please help,
Matt

@mikejolley

This comment has been minimized.

Show comment
Hide comment
@mikejolley

mikejolley Jun 13, 2017

Member

This report lacks examples, steps to reproduce, system status report.

BEFORE POSTING YOUR ISSUE
- These comments won't show up when you submit the issue.
- Try to add as much detail as possible. Be specific!
- GitHub issues ARE NOT FOR SUPPORT! If you have questions, use the either:
  - https://wordpress.org/support/plugin/woocommerce for general support
  - https://woocommerce.com/my-account/tickets/ for premium plugin support
- If you're requesting a new feature, explain why you'd like it to be added.
- Search this repository (top of the page) for the issue and it has not been fixed or reported already.

Before logging BUGS, ensure you:
- Use the latest stable release of WooCommerce.
- Disabled all plugins to ensure it's a core bug and not a plugin issue.
- Switched to Twenty Twelve theme to ensure it's a core bug and not a theme issue.

If you can tell us how to replicate on a clean install I'll look into this.

Member

mikejolley commented Jun 13, 2017

This report lacks examples, steps to reproduce, system status report.

BEFORE POSTING YOUR ISSUE
- These comments won't show up when you submit the issue.
- Try to add as much detail as possible. Be specific!
- GitHub issues ARE NOT FOR SUPPORT! If you have questions, use the either:
  - https://wordpress.org/support/plugin/woocommerce for general support
  - https://woocommerce.com/my-account/tickets/ for premium plugin support
- If you're requesting a new feature, explain why you'd like it to be added.
- Search this repository (top of the page) for the issue and it has not been fixed or reported already.

Before logging BUGS, ensure you:
- Use the latest stable release of WooCommerce.
- Disabled all plugins to ensure it's a core bug and not a plugin issue.
- Switched to Twenty Twelve theme to ensure it's a core bug and not a theme issue.

If you can tell us how to replicate on a clean install I'll look into this.

@mikejolley mikejolley closed this Jun 13, 2017

@Matekk

This comment has been minimized.

Show comment
Hide comment
@Matekk

Matekk Jun 14, 2017

Nevermind, I was modifying wc session data which caused the errors, fixed.

Matekk commented Jun 14, 2017

Nevermind, I was modifying wc session data which caused the errors, fixed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment