Skip to content
Packagist API Bundle for Symfony 3 and 4
PHP
Branch: master
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.

Files

Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
Command
DTO
DependencyInjection
Exception
Resources/config
Service
.scrutinizer.yml
CHANGELOG.md
LICENCE
README.md
WowAppsPackagistBundle.php
composer.json

README.md

Symfony Packagist Banner

SensioLabsInsight

Packagist Packagist Build Status Scrutinizer Code Quality GitHub license Code Climate Codacy Badge SensioLabsInsight

Symfony Packagist API Bundle

Packagist API Bundle for Symfony 3 and 4

Requires:

  • PHP 7.0+
  • Symfony 3.0+
  • Guzzle Client 6.0+

Installation

Step 1: Download the Bundle

"require": {
        "wow-apps/symfony-packagist": "^1.3"
}

or

$ composer require wow-apps/symfony-packagist 

Step 2: Enable the Bundle (skip for Symfony 4)

// ./app/AppKernel.php

public function registerBundles()
{
    $bundles = array(
        // ...
        new WowApps\PackagistBundle\WowAppsPackagistBundle(),
    );

    // ...

    return $bundles
}

Documentation

News and updates:

Follow news and updates in my Telegram channel @wow_apps_pro or Twitter @alexey_samara_

Say thanks:

I don't ask for donates, I do what I do for free, for all development community. But I will be grateful if you inform me on the email in which project you are using this Bundle, as well as I will be glad to criticize and suggestions.

e-mail

Changelog:

  • 1.4.0
    • Added multiple requests concurrently for getting packages using promises and asynchronous requests
    • Fixed service container name in commands

Symfony Packagist Preview

You can’t perform that action at this time.