Permalink
Browse files

Merge pull request #110 from wp-cli/adapt-for-v2

Adapt package for framework v2
  • Loading branch information...
schlessera committed Aug 4, 2018
2 parents c260be5 + 9d6fdc3 commit 096c86631d66577090f8bd0517c7e7f97eb122a7
View
@@ -2,6 +2,7 @@ sudo: false
dist: trusty
language: php
php: 7.2
notifications:
email:
@@ -21,24 +22,6 @@ env:
- PATH="$TRAVIS_BUILD_DIR/vendor/bin:$PATH"
- WP_CLI_BIN_DIR="$TRAVIS_BUILD_DIR/vendor/bin"
matrix:
include:
- php: 7.2
env: WP_VERSION=latest
- php: 7.1
env: WP_VERSION=latest
- php: 7.0
env: WP_VERSION=latest
- php: 5.6
env: WP_VERSION=latest
- php: 5.6
env: WP_VERSION=3.7.11
- php: 5.6
env: WP_VERSION=trunk
- php: 5.3
dist: precise
env: WP_VERSION=latest
before_install:
- |
# Remove Xdebug for a huge performance increase:
@@ -50,14 +33,42 @@ before_install:
- |
# Raise PHP memory limit to 2048MB
echo 'memory_limit = 2048M' >> ~/.phpenv/versions/$(phpenv version-name)/etc/conf.d/travis.ini
- composer validate
install:
- composer require wp-cli/wp-cli:dev-master
- composer install
- bash bin/install-package-tests.sh
before_script:
- composer validate
- composer prepare-tests
script:
- bash bin/test.sh
- composer phpunit
- composer behat
jobs:
include:
- stage: sniff
script:
- composer lint
- composer phpcs
env: BUILD=sniff
- stage: test
php: 7.2
env: WP_VERSION=latest
- stage: test
php: 7.1
env: WP_VERSION=latest
- stage: test
php: 7.0
env: WP_VERSION=latest
- stage: test
php: 5.6
env: WP_VERSION=latest
- stage: test
php: 5.6
env: WP_VERSION=3.7.11
- stage: test
php: 5.6
env: WP_VERSION=trunk
- stage: test
php: 5.4
dist: precise
env: WP_VERSION=latest

This file was deleted.

Oops, something went wrong.
View

This file was deleted.

Oops, something went wrong.
View
@@ -1,11 +1,8 @@
{
"name": "wp-cli/db-command",
"description": "Performs basic database operations using credentials stored in wp-config.php.",
"type": "wp-cli-package",
"description": "Performs basic database operations using credentials stored in wp-config.php.",
"homepage": "https://github.com/wp-cli/db-command",
"support": {
"issues": "https://github.com/wp-cli/db-command/issues"
},
"license": "MIT",
"authors": [
{
@@ -14,18 +11,16 @@
"homepage": "https://runcommand.io"
}
],
"minimum-stability": "dev",
"prefer-stable": true,
"autoload": {
"psr-4": {
"": "src/"
},
"files": [ "db-command.php" ]
"require": {
"wp-cli/wp-cli": "^2"
},
"require": {},
"require-dev": {
"behat/behat": "~2.5",
"wp-cli/wp-cli": "^1.5"
"wp-cli/entity-command": "^1.3",
"wp-cli/wp-cli-tests": "^0"
},
"config": {
"sort-packages": true,
"process-timeout": 7200
},
"extra": {
"branch-alias": {
@@ -50,5 +45,31 @@
"db size",
"db columns"
]
},
"autoload": {
"psr-4": {
"": "src/"
},
"files": [
"db-command.php"
]
},
"minimum-stability": "dev",
"prefer-stable": true,
"scripts": {
"behat": "run-behat-tests",
"lint": "run-linter-tests",
"phpcs": "run-phpcs-tests",
"phpunit": "run-php-unit-tests",
"prepare-tests": "install-package-tests",
"test": [
"@lint",
"@phpcs",
"@phpunit",
"@behat"
]
},
"support": {
"issues": "https://github.com/wp-cli/db-command/issues"
}
}
Oops, something went wrong.

0 comments on commit 096c866

Please sign in to comment.