Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Composer installation instructions are dated and incorrect #279

Merged
merged 3 commits into from Feb 16, 2019

Conversation

@kimdcottrell
Copy link
Contributor

commented Feb 14, 2019

The installation instructions changed back when wp-cli 2 was released: https://make.wordpress.org/cli/2018/08/08/wp-cli-v2-0-0-release-notes/

kimdcottrell added some commits Feb 14, 2019

Original commit missed the rest of the composer setup
- moved `psy/psysh` out of the recommended composer `require` block 
- provided an optional script that adds any suggested scripts from the `wp-cli/wp-cli-bundle` into the composer `require-dev` block
- verified the `wp-completion.bash` location is still accurate
- `create-project` method of installation moves the location of `bin/wp`; edited for debian, **not sure about windows**
- changed version on `create-project` "Installing a specific version" to a valid `wp-cli-bundle` version
- globally installed as a project binary location changed

All testing was done on a Docker PHP 7.2 container that used debian-slim as the underlying OS.
@kimdcottrell

This comment has been minimized.

Copy link
Contributor Author

commented Feb 16, 2019

This PR is in reference to the bug reported here: #271

@schlessera schlessera added this to the 2.2.0 milestone Feb 16, 2019

@schlessera

This comment has been minimized.

Copy link
Member

commented Feb 16, 2019

Awesome, thanks for the PR, @kimdcottrell !

@schlessera schlessera merged commit 6a37b0a into wp-cli:master Feb 16, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
2 participants
You can’t perform that action at this time.