New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot install package from private repo #76

Closed
NicktheGeek opened this Issue Apr 10, 2018 · 1 comment

Comments

4 participants
@NicktheGeek

NicktheGeek commented Apr 10, 2018

In previous versions of WP-CLI it was possible to install packages from private repos so long as the command line user had access to that repo.

As of at least WP-CLI 1.5.0 this is no longer possible and attempting to install a package from a private repo resulted in an error:

wp package install git@github.com:{private/repo}.git
Error: Couldn't download composer.json file from 'https://raw.githubusercontent.com/{private/repo}/master/composer.json' (HTTP code 404).

This appears to be a result of the HTTPS for the raw.githubusercontent.com not being authenticated from the command line.

curl https://raw.githubusercontent.com/{private/repo}/master/composer.json
404: Not Found

This may be a result of #31

@emirpprime

This comment has been minimized.

emirpprime commented Apr 13, 2018

Put together an attempted fix in #78
Unavailable composer.json (from private repo or other reason) will no longer be fatal due to package name validation function.

@danielbachhuber danielbachhuber added this to the 1.0.13 milestone Apr 14, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment