Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Impossible to activate Pro v150919 (release candidate) #566

Closed
Kalfer opened this issue Sep 21, 2015 · 6 comments

Comments

Projects
None yet
3 participants
@Kalfer
Copy link

commented Sep 21, 2015

When I install and activate the plugin, Wordpress returns an error:

Catchable fatal error: Argument 1 passed to WebSharks\ZenCache\Pro\Plugin::WebSharks\ZenCache\Pro{closure}() must be of the type array, string given in /home/XXXXX/public_html/wp-content/plugins/zencache-pro/src/includes/closures/Plugin/NoticeUtils.php on line 255

@jaswrks jaswrks added bug pro labels Sep 21, 2015

@jaswrks

This comment has been minimized.

Copy link

commented Sep 21, 2015

@raamdev raamdev added this to the Next Release (Pro) milestone Sep 21, 2015

@jaswrks

This comment has been minimized.

Copy link

commented Sep 22, 2015

Next Actions

  • New feature branch: feature/566 in the websharks/zencache-pro repo.

  • After this line of code add the following:

    continue; // Bypass; i.e., do not normalize.
  • Submit PR.

raamdev added a commit to wpsharks/comet-cache-pro that referenced this issue Sep 22, 2015

@raamdev

This comment has been minimized.

Copy link
Contributor

commented Sep 22, 2015

@Kalfer Thanks so much for reporting this issue with the RC! We've fixed the bug and will be releasing a second RC in a few hours. If you could test this second RC once it's released to confirm that you don't get any error message, that would be very helpful. :-)

@raamdev raamdev closed this Sep 22, 2015

@raamdev

This comment has been minimized.

Copy link
Contributor

commented Sep 24, 2015

@Kalfer ZenCache Pro v150924 RC2 has been released, which includes the fix for this issue. If you're able to test RC2 to confirm this issue has been fixed, that would be great! :-) See http://zencache.com/zencache-pro-v150924-release-candidate-2/

@Kalfer

This comment has been minimized.

Copy link
Author

commented Sep 24, 2015

Yes, the bug has been fixed. Now I was able to install and activate it perfectly. Thanks.

@raamdev

This comment has been minimized.

Copy link
Contributor

commented Sep 24, 2015

@Kalfer Awesome! Thanks so much for testing and confirming. :-)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.