Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bug: Comet Cache prompting users to upgrade to v160316. #727

Closed
renzms opened this issue Mar 29, 2016 · 4 comments
Closed

Bug: Comet Cache prompting users to upgrade to v160316. #727

renzms opened this issue Mar 29, 2016 · 4 comments
Assignees
Milestone

Comments

@renzms
Copy link

@renzms renzms commented Mar 29, 2016

Related to: #678

Customers have been reporting an issue where Comet Cache is prompting them to update to ​Comet Cache v160316​ however, only ​ZenCache has a v160316​. Latest installed version of Comet Cache and the available file you get from cometcache.com is ​v160227​.

ccv160316

Findings from @jaswsinc

The problem will impact users who upgraded to the latest release of ZenCache, or who had ZenCache installed long enough for it to do a recent update check, where their configured options include that ZenCache version number. Whenever they update to Comet Cache, that version is carried over into their new Comet Cache options, resulting in this unexpected behavior.

Referencing: https://github.com/websharks/comet-cache-pro/blob/160227/src/includes/closures/Plugin/OptionUtils.php#L17 where we should be deleting that option after importing the old ZenCache options.

Workaround

In Comet Cache please click Restore Default Options.

Note if this does not work either, then it could be that you haven't completely deleted ZenCache from your installation yet. Please see the following steps to remove ZenCache:

  • Install ZenCache and turn off Deletion Safeguards in your ZenCache config options.
  • Deactivate and delete ZenCache entirely.
  • Install Comet Cache.

Or, another way to resolve this....

  • In PHP, run delete_site_option('zencache_options');
  • In Comet Cache click Restore Default Options.

Referencing internal ticket(s):
https://websharks.zendesk.com/agent/tickets/11884
https://websharks.zendesk.com/agent/tickets/11841

@renzms renzms added the bug label Mar 29, 2016
@jaswrks
Copy link

@jaswrks jaswrks commented Mar 31, 2016

@renzms Thanks for opening this report! :-)

Next Steps for a PR

  • After this line please add the following:

    $options['latest_lite_version'] = $this->default_options['latest_lite_version'];
    $options['latest_pro_version'] = $this->default_options['latest_pro_version'];
@jaswrks
Copy link

@jaswrks jaswrks commented Apr 1, 2016

For the benefit of others coming to this issue...

Noting that we have a release archive available here where you can acquire older versions of ZenCache.
Please see: https://cometcache.com/release-archive/

@raamdev raamdev added this to the Next Release milestone Apr 4, 2016
@raamdev
Copy link
Contributor

@raamdev raamdev commented Apr 5, 2016

Next Release Changelog:

  • Bug Fix (Pro): Fixed a bug related to the Pro Updater where some users who had migrated from ZenCache Pro to Comet Cache Pro were seeing an invalid new version message. Props @renzms @jaswsinc. See Issue #727
@raamdev
Copy link
Contributor

@raamdev raamdev commented Apr 16, 2016

Comet Cache v160416 has been released and includes changes from this GitHub Issue. See the v160416 announcement for further details.


This issue will now be locked to further updates. If you have something to add related to this GitHub Issue, please open a new GitHub Issue and reference this one (#727).

@wpsharks wpsharks locked and limited conversation to collaborators Apr 16, 2016
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants