Skip to content
master
Switch branches/tags
Code

Latest commit

 

Git stats

Files

Permalink
Failed to load latest commit information.
Type
Name
Latest commit message
Commit time
en
 
 
 
 
 
 
 
 
 
 

WSO2 Identity Server Documentation

End-user apps in WSO2 Identity Server

Branch Build Status
master Build Status

Prerequisites

To run the project locally, it requires python & pip.

Install Python

Check if you already have Python installed by running the following command.

$ python --version
Python 2.7.10

If you receive a response similar to the one shown above, Python 2.7.10 is your default version.

You should also check if you have Python 3 installed.

$ python3 --version
Python 3.8.0

If you don't seem to have Python installed, grab the latest release from the official downloads page.

Install pip

pip is already installed if you are using Python 2 >=2.7.9 or Python 3 >=3.4 downloaded from python.org or if you are working in a Virtual Environment created by virtualenv or pyvenv. Just make sure to upgrade pip.

Installing with get-pip.py

To install pip with curl, execute the following command. Alternatively you can download get-pip.py by clicking here.

$ curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py

Then run the following command in the folder where you have downloaded get-pip.py

$ python get-pip.py

Run project locally (Dev Mode)

Clone the repo

$ git clone https://github.com/wso2/docs-is.git

Install the dependencies

$ cd docs-is && pip install -r requirements.txt

Run mkdocs

Execute the following command from inside the <Lang folder>.

$ cd en && mkdocs serve

License

Licenses this source under the Apache License, Version 2.0 (LICENSE), You may not use this file except in compliance with the License.