Permalink
Browse files

Don't install/run gometalinter on Go < 1.9 (#191)

  • Loading branch information...
jlyon1 authored and kochman committed Jan 28, 2019
1 parent 7aae23c commit bd2b437dee0d55e04bca85e03d7a91d14e31bc15
Showing with 3 additions and 3 deletions.
  1. +3 −3 .travis.yml
@@ -21,7 +21,7 @@ addons:

before_install:
- go get -u github.com/kardianos/govendor && govendor sync -v
- go get -u github.com/alecthomas/gometalinter && gometalinter --install
- if [ "go version go1.8.7 linux/amd64" != "$(go version)" ] && [ "go version go1.7.6 linux/amd64" != "$(go version)" ]; then go get -u github.com/alecthomas/gometalinter && gometalinter --install; fi
- go get -u github.com/bradleyfalzon/revgrep/...
- cd frontend && npm install && npm run build && cd ..

@@ -32,8 +32,8 @@ before_script:
- psql -c 'create database shuttletracker_test;' -U postgres

script:
- if [ "$TRAVIS_PULL_REQUEST" != "false" ]; then gometalinter --vendor ./... 2>&1 | revgrep origin/master; fi
- if [ "$TRAVIS_PULL_REQUEST" = "false" ]; then gometalinter --vendor ./... || true; fi
- if [ "$TRAVIS_PULL_REQUEST" != "false" ] && [ "go version go1.8.7 linux/amd64" != "$(go version)" ] && [ "go version go1.7.6 linux/amd64" != "$(go version)" ]; then gometalinter --vendor ./... 2>&1 | revgrep origin/master; fi
- if [ "$TRAVIS_PULL_REQUEST" = "false" ] && [ "go version go1.8.7 linux/amd64" != "$(go version)" ] && [ "go version go1.7.6 linux/amd64" != "$(go version)" ]; then gometalinter --vendor ./... || true; fi
- ./test.sh
- docker build .
- bash <(curl -s https://codecov.io/bash)

0 comments on commit bd2b437

Please sign in to comment.