Skip to content
Browse files

Install the README when building the RPM. Use the bzip2-compressed

tarball for RPM. Don't install the LICENSE file, Debian doesn't like
that. Add a fix for RPM gzipping manual pages when installing.
  • Loading branch information...
1 parent aba49ba commit 9f28017a11e83b9eee33ccb013e203791f5a89a6 Jan Urbański committed Jan 30, 2009
Showing with 6 additions and 1 deletion.
  1. +2 −0 fix-rpm-compressing-files
  2. +3 −0 setup.cfg
  3. +1 −1 setup.py
View
2 fix-rpm-compressing-files
@@ -0,0 +1,2 @@
+python setup.py install --root="$RPM_BUILD_ROOT" --record=INSTALLED_FILES
+sed -i -e 's/.*man.*\.[0-9]$/&.gz/' INSTALLED_FILES
View
3 setup.cfg
@@ -6,6 +6,9 @@ release = 1
build_requires = python >= 2.4
requires = python >= 2.4
provides = flvlib
+doc_files = README
+use_bzip2 = 1
+install_script = fix-rpm-compressing-files
[install]
optimize = 1
View
2 setup.py
@@ -18,7 +18,7 @@
if sys.platform == 'linux2':
data_files = [('share/man/man1', ['man/debug-flv.1', 'man/index-flv.1']),
('share/doc/flvlib-%s' % __versionstr__,
- ['README', 'LICENSE'])]
+ ['README'])]
else:
data_files = []

0 comments on commit 9f28017

Please sign in to comment.
Something went wrong with that request. Please try again.