Problem installing oily_png on OSX #12

Closed
mattgrande opened this Issue Apr 16, 2014 · 1 comment

Comments

Projects
None yet
1 participant
@mattgrande

I'm getting an error when trying to install oily_png on OSX:

$ ruby -v
ruby 2.0.0p247 (2013-06-27 revision 41674) [universal.x86_64-darwin13]
$ sudo gem install oily_png
Fetching: chunky_png-1.3.0.gem (100%)
Successfully installed chunky_png-1.3.0
Fetching: oily_png-1.1.1.gem (100%)
Building native extensions.  This could take a while...
ERROR:  Error installing oily_png:
    ERROR: Failed to build gem native extension.

    /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/bin/ruby extconf.rb
creating Makefile

make "DESTDIR="
compiling color.c
compiling oily_png_ext.c
oily_png_ext.c:43:1: warning: control may reach end of non-void function [-Wreturn-type]
}
^
1 warning generated.
compiling operations.c
compiling png_decoding.c
png_decoding.c:315:1: warning: control may reach end of non-void function [-Wreturn-type]
}
^
1 warning generated.
compiling png_encoding.c
png_encoding.c:239:1: warning: control may reach end of non-void function [-Wreturn-type]
}
^
1 warning generated.
compiling resampling.c
linking shared-object oily_png/oily_png.bundle
clang: error: unknown argument: '-multiply_definedsuppress' [-Wunused-command-line-argument-hard-error-in-future]
clang: note: this will be a hard error (cannot be downgraded to a warning) in the future
make: *** [oily_png.bundle] Error 1

Note the error: clang: error: unknown argument: '-multiply_definedsuppress' [-Wunused-command-line-argument-hard-error-in-future].

According to this Stack Overflow question, it's a problem with building with XCode 5.1+ installed. I'm not sure if this is something you can fix (I don't see that code in this project), but I wanted to make you aware of it.

@mattgrande

This comment has been minimized.

Show comment
Hide comment
@mattgrande

mattgrande Apr 16, 2014

Shit, I should've read further in that SO question. The problem is with the ruby install. Closing.

Shit, I should've read further in that SO question. The problem is with the ruby install. Closing.

@mattgrande mattgrande closed this Apr 16, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment