New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

wx.html2.EVT_WEBVIEW_NAVIGATING is not called in Ubuntu 16.04 #741

Closed
Jenyay opened this Issue Feb 9, 2018 · 11 comments

Comments

Projects
None yet
4 participants
@Jenyay
Contributor

Jenyay commented Feb 9, 2018

Operating system: Ubuntu 16.04
wxPython version: 4.0.1
Stock or custom build: from PyPi
Python version: Python 3.5
Stock or custom build: stock

In Ubuntu 16.04 with Python 3.5 wx.html2.EVT_WEBVIEW_NAVIGATING is not called when clicking on a link in the loaded with wx.html2.WebView class HTML file.

In Ubuntu 17.10 with Python 3.6 the event work fine.

@swt2c

This comment has been minimized.

Contributor

swt2c commented Feb 9, 2018

This is probably a wx issue. In each case, are you using WebKit1 or WebKit2?

@Jenyay

This comment has been minimized.

Contributor

Jenyay commented Feb 9, 2018

WebKit2.

@Jenyay

This comment has been minimized.

Contributor

Jenyay commented Feb 10, 2018

The problem turned out to be more interesting than I thought at first.

With WebKit1 the EVT_WEBVIEW_NAVIGATING event work fine, but with WebKit2 the event is not called. It turns out that in Ubuntu 17.10 I did not have the libwebkit2gtk -...- dev library installed (and everything worked perfectly).

In Ubuntu 16.04 I have libwebkitgtk-3.0-dev and libwebkit2gtk-4.0-dev and the EVT_WEBVIEW_NAVIGATING event is not called.

The problem with WebKit2, but not WebKit1. The Ubuntu version is not important.

PS. The EVT_WEBVIEW_NAVIGATED and EVT_WEBVIEW_LOADED events is called with WebKit1 and WebKit2.

@swt2c

This comment has been minimized.

Contributor

swt2c commented Feb 10, 2018

That's good news. I have some ideas about what the problem is (in wxWidgets).

@swt2c

This comment has been minimized.

Contributor

swt2c commented Feb 10, 2018

This was fixed upstream by b4bcb8e4483ffb67d336021c40e2d9455082e97e while fixing a different bug. If/when Robin does another 4.0.x release and updates the wx commit, this should be fixed.

@Jenyay

This comment has been minimized.

Contributor

Jenyay commented Feb 10, 2018

Thank you, I will wait for the next version.

mesalu added a commit to mesalu/Phoenix that referenced this issue Feb 11, 2018

RobinD42 added a commit that referenced this issue Feb 14, 2018

Merge pull request #745 from mesalu/update_wxref
Bump the submodule reference on wxPy-4.0.x. Fixes #741, and probab…

@RobinD42 RobinD42 closed this Feb 14, 2018

@mesalu

This comment has been minimized.

Collaborator

mesalu commented Feb 14, 2018

The wxWidgets reference has been updated to include @swt2c's changes now. The next formal release from the 4.0.X branch will include the change.

@Jenyay

This comment has been minimized.

Contributor

Jenyay commented Aug 29, 2018

I saw one more problem. EVT_WEBVIEW_NAVIGATING is not called if on the loaded HTML page to click on the relative link or a link with file:// protocol.

Python 3.5. Ubuntu 16.04. wxPython 4.0.3.

@swt2c

This comment has been minimized.

Contributor

swt2c commented Aug 29, 2018

@Jenyay probably open a new issue, since this one is closed.

@Jenyay

This comment has been minimized.

Contributor

Jenyay commented Aug 29, 2018

If the message is not noticed here, then I will create a new issue.

@swt2c

This comment has been minimized.

Contributor

swt2c commented Aug 29, 2018

Well, I'm probably the one who would do something about it, so technically I've noticed it but I'll probably forget. ;-)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment