Permalink
Commits on Jan 3, 2012
  1. Clean up module usage. There's no need to use InstanceMethods -- norm…

    …al Ruby modules and includes will work fine here.
    committed Jan 3, 2012
Commits on Dec 14, 2011
  1. Merge pull request #33 from nbudin/master

    Use connection pool instead of actual connection on load (helps with Rails 3.1 on Heroku)
    zdennis committed Dec 14, 2011
Commits on Oct 10, 2011
  1. Use connection pool instead of actual connection to avoid having to c…

    …onnect to the database until necessary
    nbudin committed Oct 10, 2011
Commits on Aug 14, 2011
  1. Bumping to 0.2.8

    zdennis committed Aug 14, 2011
Commits on Jul 13, 2011
  1. Bumping VERSION to 0.2.8.rc3

    zdennis committed Jul 13, 2011
  2. Merge pull request #27 from msgehard/fix_gemfile

    Relax pg version dependency a bit.
    zdennis committed Jul 13, 2011
  3. Relax pg version dependency a bit. The Gemfile specifies pg ~>0.9.0 a…

    …nd Rails 3.1 specifies pg 0.11 so there is no way for bundler to install pg for a new download.
    mikegehard committed Jul 13, 2011
Commits on Jun 23, 2011
  1. Bumping VERSION to 0.2.8.rc2

    zdennis committed Jun 23, 2011
  2. Merge pull request #21 from jamiecobbett/master

    Fix import of very large datasets containing multibyte chars on Ruby 1.9
    zdennis committed Jun 23, 2011
  3. Merge pull request #26 from fallwith/master

    Ruby 1.9.2 / RubyGems 1.8.5 compatibility fix (pass String instead of Pathname to require)
    zdennis committed Jun 23, 2011
  4. Updating Gemfile to include activerecord ~> 3.0 instead of 3.0.0 so i…

    …t works with 3.1.
    
    [fixes #24]
    zdennis committed Jun 23, 2011
Commits on Jun 22, 2011
  1. Regexp.escape which is called by Gem.loaded_path? (/usr/local/lib/rub…

    …y/site_ruby/1.9.1/rubygems.rb) expects the path as a String, not a Pathname. Convert Pathnames to Strings prior to calling 'require'
    fallwith committed Jun 22, 2011
Commits on May 8, 2011
  1. Correctly obey MySQL MAX PACKET

    Use String's bytesize instead of size, because we're talking about byte length,
    not string length. This resolves a problem on Ruby 1.9 with multi-byte
    characters.
    Jamie Cobbett committed May 8, 2011
Commits on May 5, 2011
  1. Adding jdbcmysql support.

    Jason committed with zdennis Apr 6, 2011
Commits on May 4, 2011
  1. Updating import_test to be Ruby 1.9.2 compatible. Ruby 1.9.1 changed …

    …the Date.parse capabilities to no longer support MM/DD/YYYY functionality so we only test against YYYY/MM/DD.
    
    [fixes zdennis#19]
    zdennis committed May 4, 2011
Commits on Apr 29, 2011
  1. Version bump to 0.2.7

    zdennis committed Apr 29, 2011
  2. Do not use ActiveRecord::Base.new(hsh) when instantiating AR models. …

    …Use form of instantiation that allows protected attributes to be set.
    zdennis committed Apr 29, 2011
Commits on Apr 6, 2011
  1. Version bump to 0.2.6

    zdennis committed Apr 6, 2011
  2. Version bump to 0.3.0

    zdennis committed Apr 6, 2011
  3. Added :synchronize_keys to the import options so importing can synchr…

    …onize on fields beside the primary key.
    
    zdennis#16
    zdennis committed Apr 6, 2011
Commits on Mar 19, 2011
  1. Adding in support for :synchronization option for #import. Pulled in …

    …from ar-extensions. Currently only works with MySQL since that is the only database that supports on duplicate key update functionality.
    
    https://github.com/zdennis/activerecord-import/issues#issue/6
    zdennis committed Mar 19, 2011
  2. Turning off warnings because FactoryGirl spews out crap and it makes …

    …it impossible to see anything useful.
    zdennis committed Mar 19, 2011
Commits on Jan 12, 2011
  1. Version bump to 0.2.5

    zdennis committed Jan 12, 2011
Commits on Jan 11, 2011
  1. Renamed #values_sql_for_column_names_and_attributes to #values_sql_fo…

    …r_columns_and_attributes and cleaned up how it dealt with columns.
    
    * added back in the support for type-casting based on the database column
    * removed unused method in ActiveRecord::Import::AbstractAdapter
    
    https://github.com/zdennis/activerecord-import/issues#issue/5
    zdennis committed Jan 11, 2011