New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

github hosted gem seems dated and buggy #2

Closed
bumi opened this Issue Jun 1, 2009 · 4 comments

Comments

Projects
None yet
4 participants
@bumi

bumi commented Jun 1, 2009

The github hosted gem seems dated:

The Moneta::Memcache#key? method in the installed gem looks like:

def key?(key)
!self["key"].nil?
end

which does not work ("key" vs. key).
Is there a way to update the gem?

thanks.

@mwilliams

This comment has been minimized.

mwilliams commented Jun 3, 2009

+1 for this. Pulled down the latest and the S3 additions didn't get included in the gem I installed.

sudo gem install wycats-moneta --no-rdoc --no-ri
Successfully installed wycats-moneta-0.6.0

Shouldn't this line in the gemspec include everything in /lib/moneta?

s.files = ["LICENSE", "README", "Rakefile", "TODO", "lib/moneta", "lib/moneta/datamapper.rb", "lib/moneta/file.rb", "lib/moneta/memcache.rb", "lib/moneta/memory.rb", "lib/moneta/xa
@wycats

This comment has been minimized.

Owner

wycats commented Jul 15, 2009

I'll try and get to this before this weekend. It's tough keeping this up to date as I pull from multiple forks. Git isn't that good.

@bumi

This comment has been minimized.

bumi commented Jul 16, 2009

thanks.
Perhaps a note in the readme on how to build the gemspec and install the gem from a local cloned repo is enough?

@minad

This comment has been minimized.

Contributor

minad commented Dec 20, 2012

I will update the gem on rubygems.org soon

@minad minad closed this Dec 20, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment